summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Wolfer2016-01-08 23:16:14 +0100
committerPhilipp Wolfer2016-01-08 23:16:14 +0100
commit9b36a3cc438b3f0665610039c593ac2148be555e (patch)
tree861441c02dbecea226ebcae76b15e33ab5af5444
parent4c42144f4f000db835ef469399e08abddca5c5ee (diff)
downloadaur-9b36a3cc438b3f0665610039c593ac2148be555e.tar.gz
New release 0.4.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f18feba6f087..789f19365fac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jan 8 08:02:46 UTC 2016
+# Fri Jan 8 22:16:14 UTC 2016
pkgbase = peek
pkgdesc = Peek - animated GIF recorder
- pkgver = 0.3.0
+ pkgver = 0.4.0
pkgrel = 1
url = https://github.com/phw/peek
install = peek.install
@@ -15,7 +15,7 @@ pkgbase = peek
depends = gtk3
depends = ffmpeg
depends = imagemagick
- source = git+https://github.com/phw/peek.git#tag=v0.3.0
+ source = git+https://github.com/phw/peek.git#tag=v0.4.0
sha1sums = SKIP
pkgname = peek
diff --git a/PKGBUILD b/PKGBUILD
index 13ff86057f07..dcd68a8a66a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Philipp Wolfer <ph.wolfer@gmail.com>
pkgname=peek
-pkgver=0.3.0
+pkgver=0.4.0
pkgrel=1
pkgdesc="Peek - animated GIF recorder"
arch=('i686' 'x86_64')
@@ -14,13 +14,16 @@ sha1sums=('SKIP')
build() {
cd "${srcdir}/peek"
- cmake -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr -DGSETTINGS_COMPILE=OFF .
+ cmake -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr \
+ -DBUILD_TESTS \
+ -DGSETTINGS_COMPILE=OFF .
make
}
-#check() {
-# cd "${srcdir}/peek"
-#}
+check() {
+ cd "${srcdir}/peek"
+ make test
+}
package() {
cd "${srcdir}/peek"