summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-09-29 10:42:09 +1300
committercaltlgin2020-09-29 10:42:09 +1300
commit62089f3069d401709cdede884b23e5ab1dc13e77 (patch)
tree26d8d295807d758a455ab8f622ab486713830d36
downloadaur-peeq-bin.tar.gz
Add to AUR
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..450542312cfd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = peeq-bin
+ pkgdesc = Postgresql Client with programmer utilities
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/dbhowell/peeq
+ arch = x86_64
+ license = GPL3
+ depends = granite
+ depends = gtksourceview3
+ depends = postgresql-libs
+ provides = peeq
+ source = http://packages.elementary.io/appcenter/pool/main/c/com.github.dbhowell.peeq/com.github.dbhowell.peeq0.5.0-02a0c5.deb
+ sha256sums = 263e27b1d4e75074220eb29629ea51c8b2b1d3020359c9000eee682cd12fadff
+
+pkgname = peeq-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83260825c5d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_binary_name='com.github.dbhowell.peeq'
+_pkgname="${_binary_name##*.}"
+pkgname="${_pkgname}-bin"
+pkgver=0.5.0
+pkgrel=1
+_pkg_hash='02a0c5' # <-- NB: update on new version
+pkgdesc='Postgresql Client with programmer utilities'
+arch=('x86_64')
+url='https://github.com/dbhowell/peeq'
+_pool_url='http://packages.elementary.io/appcenter/pool/main'
+license=('GPL3')
+depends=('granite' 'gtksourceview3' 'postgresql-libs')
+provides=("${_pkgname}")
+source=("${_pool_url}/${_binary_name::1}/${_binary_name}/${_binary_name}${pkgver}-${_pkg_hash}.deb")
+sha256sums=('263e27b1d4e75074220eb29629ea51c8b2b1d3020359c9000eee682cd12fadff')
+
+package() {
+ tar -xvf data.tar.xz -C "${pkgdir}"
+ rm -rf "${pkgdir}/usr/share/doc"
+}
+
+# vim: ts=2 sw=2 et: