summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPavan Rikhi2019-11-11 06:35:23 -0500
committerPavan Rikhi2019-11-11 06:37:15 -0500
commit07a16933f31f81607891538af1795082fdd80c3c (patch)
tree598908bd8ebfb82b15f2be8b45c6ebe9b10d7d49
parent98dd89aea4f008e7425c576b3ad451e9ddf9cea6 (diff)
downloadaur-07a16933f31f81607891538af1795082fdd80c3c.tar.gz
Update to v3.1.0
Note: this includes a custom package.json since the released version throws configuration errors when building the package.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
-rw-r--r--fixed-package.json84
3 files changed, 100 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9b646fc3eba..1600d3bd6d05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pencil
pkgdesc = Sketching and GUI prototyping/wireframing tool
- pkgver = 3.0.4
- pkgrel = 3
+ pkgver = 3.1.0
+ pkgrel = 1
url = http://github.com/evolus/pencil
arch = any
license = GPL2
@@ -15,12 +15,14 @@ pkgbase = pencil
depends = alsa-lib
conflicts = evolus-pencil-bin
conflicts = pencil-v2
- source = https://github.com/evolus/pencil/archive/v3.0.4.tar.gz
+ source = https://github.com/evolus/pencil/archive/v3.1.0.tar.gz
source = pencil.desktop
source = pencil-mime.xml
- sha256sums = f00b06d7db9583479597db827ebe1371ad0878a947a28c97c00895e50f2476f4
+ source = fixed-package.json
+ sha256sums = e14eddd0aad28919cfdf8d47b726f9c75a3a0d2042605e8da96309c23a995f44
sha256sums = 6d467da74509e74e06325e7464a6a177164ae8977470423da6cae43265dedd4d
sha256sums = 87aac9f5005ccd57aa6b1bf190052fcc4915eff1d7bddb2723863739545e42fc
+ sha256sums = 6f0902d9d2294865b8993c94ce4f01dd01318c7da428dad5a45b7753c46ad757
pkgname = pencil
diff --git a/PKGBUILD b/PKGBUILD
index 8c475cd8692d..adaa7e9d585a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: Pavan Rikhi <pavan.rikhi@gmail.com>
pkgname=pencil
-pkgver=3.0.4
-pkgrel=3
+pkgver=3.1.0
+pkgrel=1
pkgdesc="Sketching and GUI prototyping/wireframing tool"
arch=('any')
license=('GPL2')
url="http://github.com/evolus/pencil"
source=("https://github.com/evolus/pencil/archive/v$pkgver.tar.gz"
"pencil.desktop"
- "pencil-mime.xml")
-sha256sums=('f00b06d7db9583479597db827ebe1371ad0878a947a28c97c00895e50f2476f4'
+ "pencil-mime.xml"
+ "fixed-package.json")
+sha256sums=('e14eddd0aad28919cfdf8d47b726f9c75a3a0d2042605e8da96309c23a995f44'
'6d467da74509e74e06325e7464a6a177164ae8977470423da6cae43265dedd4d'
- '87aac9f5005ccd57aa6b1bf190052fcc4915eff1d7bddb2723863739545e42fc')
+ '87aac9f5005ccd57aa6b1bf190052fcc4915eff1d7bddb2723863739545e42fc'
+ '6f0902d9d2294865b8993c94ce4f01dd01318c7da428dad5a45b7753c46ad757')
conflicts=('evolus-pencil-bin' 'pencil-v2')
depends=('nodejs' 'npm' 'libxss' 'nss' 'gconf' 'libxtst' 'gtk2' 'alsa-lib')
@@ -25,14 +27,10 @@ package() {
mkdir -p "$TMP_HOME/.config"
fi
- # Temporary fix for segfaults until next Pencil release(3.0.5+)
- HOME="$TMP_HOME" npm i -s electron@"==1.8"
- cd app/
- HOME="$TMP_HOME" npm i -s unzipper
- sed -i 's/unzip2/unzipper/' app.js
- cd ..
+ # Temporary fix of package.json for v3.1.0 builds.
+ cp -f "$srcdir/fixed-package.json" package.json
- HOME="$TMP_HOME" npm install --unsafe-perm
+ HOME="$TMP_HOME" npm ci --unsafe-perm
HOME="$TMP_HOME" node_modules/.bin/build --linux dir
install -d "$pkgdir/usr/share/$pkgname/" "$pkgdir/usr/bin" \
diff --git a/fixed-package.json b/fixed-package.json
new file mode 100644
index 000000000000..8fa5f5ecfca3
--- /dev/null
+++ b/fixed-package.json
@@ -0,0 +1,84 @@
+{
+ "name": "Pencil",
+ "author": {
+ "name": "Evolus"
+ },
+ "description": "An open-source GUI prototyping tool that is available for ALL platforms.",
+ "devDependencies": {
+ "electron": "6.0.1",
+ "electron-builder": "20.28.4",
+ "electron-rebuild": "^1.8.5",
+ "rimraf": "^2.5.4"
+ },
+ "build": {
+ "appId": "vn.evolus.pencil",
+ "productName": "Pencil",
+ "copyright": "Copyright © 2008-2016 Evolus. All rights reserved.",
+ "mac": {
+ "category": "public.app-category.graphics-design"
+ },
+ "dmg": {
+ "contents": [
+ {
+ "x": 356,
+ "y": 140,
+ "type": "link",
+ "path": "/Applications"
+ },
+ {
+ "x": 130,
+ "y": 145,
+ "type": "file"
+ }
+ ]
+ },
+ "linux": {
+ "synopsis": "An open-source GUI prototyping tool that is available for ALL platforms.",
+ "maintainer": "Nguyen Tien Dzung <ngtdungnt@gmail.com>",
+ "vendor": "Evolus",
+ "target": [
+ "deb",
+ "rpm",
+ "tar.gz"
+ ],
+ "depends": [],
+ "category": "Graphics",
+ "packageCategory": "graphics"
+ },
+ "win": {
+ "icon": "build/icon.ico",
+ "target": "nsis"
+ },
+ "nsis": {
+ "oneClick": false,
+ "perMachine": true,
+ "allowToChangeInstallationDirectory": true
+ },
+ "electronDownload": {
+ "cache": ".electron-cache"
+ },
+ "fileAssociations": {
+ "ext": [
+ "ep",
+ "epz",
+ "epgz"
+ ],
+ "name": "Pencil Document"
+ }
+ },
+ "scripts": {
+ "postinstall": "install-app-deps",
+ "install-app-deps": "node ./node_modules/electron-builder/out/install-app-deps.js",
+ "start": "./node_modules/.bin/electron ./app",
+ "start:dev": "./node_modules/.bin/electron ./app --enable-dev --enable-transparent-visuals --disable-gpu",
+ "start:mac": "./node_modules/.bin/electron ./app --enable-dev",
+ "clean": "rimraf dist",
+ "pack": "build",
+ "dist": "build",
+ "release": "build",
+ "dist:linux": "./node_modules/.bin/build --linux --ia32 --x64",
+ "dist:win32": "./node_modules/.bin/build --windows --ia32 --x64",
+ "dist:osx": "./node_modules/.bin/build --macos"
+ },
+ "private": true
+}