summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrLi2020-10-14 00:54:48 +0800
committerBrLi2020-10-14 00:54:48 +0800
commit760529b50c29e7624621fbbfac2081e1d2b7c3eb (patch)
treeaa432e68de1ce88f95e16e7cd1b29726e29999e6
parentaba0c046fce06367a70d30abb9b638453bb1ae32 (diff)
downloadaur-760529b50c29e7624621fbbfac2081e1d2b7c3eb.tar.gz
downgrade to use electron9
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06af692558eb..3066f6f7f10c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = pencil
pkgdesc = Sketching and GUI prototyping/wireframing tool
pkgver = 3.1.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/evolus/pencil
arch = any
license = GPL2
makedepends = yarn
- depends = electron
+ depends = electron9
conflicts = evolus-pencil-bin
conflicts = pencil-v2
source = https://github.com/evolus/pencil/archive/v3.1.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 9ce2db5827ac..bb9a69cdd2ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=pencil
pkgver=3.1.0
-pkgrel=5
+pkgrel=6
pkgdesc="Sketching and GUI prototyping/wireframing tool"
arch=('any')
license=('GPL2')
url="https://github.com/evolus/pencil"
-depends=(electron)
+depends=(electron9)
makedepends=(yarn)
source=("https://github.com/evolus/pencil/archive/v$pkgver.tar.gz"
'fixed-package-json.patch')
@@ -57,7 +57,7 @@ package() {
install -Dm755 /dev/stdin "${pkgdir}/usr/bin/${pkgname}" <<END
#!/bin/sh
-exec electron /${_destdir} "\$@"
+exec electron9 /${_destdir} "\$@"
END
cd "${srcdir}/${pkgname}-${pkgver}"