summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkleintux2025-01-31 16:00:03 +0100
committerkleintux2025-01-31 16:00:03 +0100
commit18fc4246deb000d6d69cb199ce56ad25db51dc34 (patch)
treebda8d643ba16ce97e304d3b80f112680bb663027
parentd0636d81def41eb093e062874514e53e0fd8b93b (diff)
downloadaur-pengupop.tar.gz
update to 2.2.6 . Rebase PKGBUILD. use source not binary
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD35
2 files changed, 30 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f53a9e2e6856..8be6479989bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = pengupop
pkgdesc = Clone of the retro arcade game Bust-a-move
- pkgver = 2.2.2
- pkgrel = 37
- url = https://fedoraproject.org/wiki/Games/pengupop
+ pkgver = 2.2.6
+ pkgrel = 1
+ url = https://mirror.amdmi3.ru/distfiles/
arch = x86_64
- license = GPL
+ license = GPL-3.0-only
depends = sdl
- source = https://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/Everything/x86_64/os/Packages/p/pengupop-2.2.2-37.fc40.x86_64.rpm
- sha256sums = 808a647c27b6c02a027a4768e888776a85bf32cd526c6d2e3a373e9ee4d13620
+ source = https://mirror.amdmi3.ru/distfiles//pengupop-2.2.6.tar.gz
+ sha256sums = f6cef1fedb11bafc947f8824533df9ca9dd6aeaa5aa795c61870b986a1fc45ba
pkgname = pengupop
diff --git a/PKGBUILD b/PKGBUILD
index 9aaf665680c9..374ca4612020 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,33 @@
# Contributor: uint2048_t
pkgname=pengupop
-pkgver=2.2.2
-_pkgver=37.fc40
-pkgrel=37
+pkgver=2.2.6
+pkgrel=1
pkgdesc="Clone of the retro arcade game Bust-a-move"
arch=('x86_64')
-url='https://fedoraproject.org/wiki/Games/pengupop'
-license=('GPL')
+url='https://mirror.amdmi3.ru/distfiles/'
+license=('GPL-3.0-only')
depends=('sdl')
-source=("https://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/Everything/x86_64/os/Packages/p/pengupop-${pkgver}-${_pkgver}.x86_64.rpm")
-sha256sums=('808a647c27b6c02a027a4768e888776a85bf32cd526c6d2e3a373e9ee4d13620')
+source=("${url}/pengupop-${pkgver}.tar.gz")
+sha256sums=('f6cef1fedb11bafc947f8824533df9ca9dd6aeaa5aa795c61870b986a1fc45ba')
-package() {
- install -Dm755 usr/bin/pengupop "${pkgdir}"/usr/bin/pengupop
- install -Dm755 usr/share/applications/pengupop.desktop "${pkgdir}"/usr/share/applications/pengupop.desktop
- install -Dm755 usr/share/icons/hicolor/48x48/apps/pengupop.png "${pkgdir}"/usr/share/icons/hicolor/48x48/apps/pengupop.png
+prepare() {
+ cd ${pkgname}-${pkgver}
+ export CFLAGS="$CFLAGS -Wno-implicit-function-declaration"
+ export CXXFLAGS="$CXXFLAGS -Wno-implicit-function-declaration"
+ autoreconf -fi
+ ./configure
+}
+
+build() {
+ cd ${pkgname}-${pkgver}
+ make
}
+package() {
+ cd ${pkgname}-${pkgver}
+ make prefix="/usr" DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 pengupop.desktop "${pkgdir}"/usr/share/applications/pengupop.desktop
+ install -Dm644 pengupop.png "${pkgdir}"/usr/share/icons/hicolor/48x48/apps/pengupop.png
+}