summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 14:01:54 -0600
committerJohn D Jones III2015-06-16 14:01:54 -0600
commit7a81671c9cc0971d4c24772d4add11bb8e125f38 (patch)
tree52a1b8ab102669b5c31b1fc5fb53423b2d7b11a4
downloadaur-perl-acpi.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
3 files changed, 80 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..51c493b95599
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = perl-acpi
+ pkgdesc = Acpi for Perl
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://search.mcpan.org/dist/Acpi
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ source = http://search.mcpan.org/CPAN/authors/id/S/SH/SHY/acpi/Acpi-0.1.tar.gz
+ options = !emptydirs
+
+pkgname = perl-acpi
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e655532f0ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-acpi
+ pkgdesc = Acpi for Perl
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://search.mcpan.org/dist/Acpi
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.mcpan.org/CPAN/authors/id/S/SH/SHY/acpi/Acpi-0.1.tar.gz
+ md5sums = 92359e674987dc492ac99be979aadd36
+ sha512sums = e795be6be950139a4fb36c837a73d22dc390189d185ee04ad761f2cf009155c825c03269a2a4525a1eb3cea7e7bcbcccf951b7237e3aacb65aa342b3658b8385
+
+pkgname = perl-acpi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0738d8a3e1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.28
+
+pkgname='perl-acpi'
+pkgver='0.1'
+pkgrel='1'
+pkgdesc="Acpi for Perl"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.mcpan.org/dist/Acpi'
+source=('http://search.mcpan.org/CPAN/authors/id/S/SH/SHY/acpi/Acpi-0.1.tar.gz')
+md5sums=('92359e674987dc492ac99be979aadd36')
+sha512sums=('e795be6be950139a4fb36c837a73d22dc390189d185ee04ad761f2cf009155c825c03269a2a4525a1eb3cea7e7bcbcccf951b7237e3aacb65aa342b3658b8385')
+_distdir="Acpi-0.1"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: