summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmish2018-12-12 15:21:57 +0530
committerAmish2018-12-12 15:21:57 +0530
commitcb82575b244e31fdc423f3b600b502e7ba81d2b1 (patch)
tree61bb44d84e1de2e9db897451c4b5e320d1af3275
parent380c7523808edbfb9d70fbec5b1542b691f72c6d (diff)
downloadaur-cb82575b244e31fdc423f3b600b502e7ba81d2b1.tar.gz
Follow perl package guidelines. Update license based on README.
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 28 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 388c32b774e7..6148c21c1da6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
-# Generated by mksrcinfo v8
-# Tue Dec 11 22:25:20 UTC 2018
pkgbase = perl-authen-pam
pkgdesc = Perl interface to PAM library
pkgver = 0.16
pkgrel = 4
- url = http://search.cpan.org/~nikip/Authen-PAM-0.16/
+ url = https://metacpan.org/release/Authen-PAM
arch = any
- license = unknown
+ license = GPL
+ license = PerlArtistic
depends = perl
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/N/NI/NIKIP/Authen-PAM-0.16.tar.gz
+ options = purge
+ source = https://cpan.metacpan.org/authors/id/N/NI/NIKIP/Authen-PAM-0.16.tar.gz
source = dotinc.patch
md5sums = 7278471dfa694d9ef312bc92d7099af2
md5sums = 09fae4f73d80b8cc9acc72105e9109d2
+ sha512sums = 2419698193697cb8c9ac3a1527a25abefffd9f15f4b492006081b2c8e7fe9e01e00f33e8fed6a07611b725b38ed92d9feb51b8ba61e4c23313cc5ff9ea1c05fd
+ sha512sums = d42c9eeeb740d8fd82d948570bb95a139d82ca404b5df43459cf423006d53f8dfac67e19ee8c8ea9cb3346d9e04a23600b4a8c2e4d9825a9c4db135ccea00b92
pkgname = perl-authen-pam
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..91b755f7e8db
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*-any.pkg.tar.xz
+Authen-PAM-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 24afeaad97bd..be67bd330ff0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,40 @@
-# CPAN Name : Authen-Simple-LDAP
# Maintainer: Jose Riha <jose1711 gmail com>
+# Maintainer: Amish <contact at via dot aur>
# Contributor: Christian Hesse <mail@earthworm.de>
-# Contributor: amish
# Contributor: mr_nuub
pkgname=perl-authen-pam
pkgver=0.16
pkgrel=4
pkgdesc="Perl interface to PAM library"
+_dist=Authen-PAM
arch=('any')
-url="http://search.cpan.org/~nikip/Authen-PAM-$pkgver/"
-license=('unknown')
+url="https://metacpan.org/release/${_dist}"
+license=('GPL' 'PerlArtistic')
depends=('perl')
-
-options=('!emptydirs')
-
-source=("http://search.cpan.org/CPAN/authors/id/N/NI/NIKIP/Authen-PAM-$pkgver.tar.gz"
+options=('!emptydirs' purge)
+source=("https://cpan.metacpan.org/authors/id/N/NI/NIKIP/${_dist}-${pkgver}.tar.gz"
"dotinc.patch")
md5sums=('7278471dfa694d9ef312bc92d7099af2'
'09fae4f73d80b8cc9acc72105e9109d2')
+sha512sums=('2419698193697cb8c9ac3a1527a25abefffd9f15f4b492006081b2c8e7fe9e01e00f33e8fed6a07611b725b38ed92d9feb51b8ba61e4c23313cc5ff9ea1c05fd'
+ 'd42c9eeeb740d8fd82d948570bb95a139d82ca404b5df43459cf423006d53f8dfac67e19ee8c8ea9cb3346d9e04a23600b4a8c2e4d9825a9c4db135ccea00b92')
prepare() {
-cd ${srcdir}/Authen-PAM-$pkgver
-patch -p1 -i ../dotinc.patch
+ cd "${srcdir}/${_dist}-${pkgver}"
+ patch -p1 -i ../dotinc.patch
}
build() {
- cd ${srcdir}/Authen-PAM-$pkgver
- export PERL_AUTOINSTALL=--skipdeps PERL_MM_USE_DEFAULT=1
- perl Makefile.PL INSTALLDIRS=vendor
+ cd "${srcdir}/${_dist}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
make
- }
+}
package() {
- cd ${srcdir}/Authen-PAM-$pkgver
+ cd "${srcdir}/${_dist}-${pkgver}"
unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
- make DESTDIR="$pkgdir" install
-
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ make install INSTALLDIRS=vendor DESTDIR="${pkgdir}"
}