summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 14:10:09 -0600
committerJohn D Jones III2015-06-16 14:10:09 -0600
commit0447a8d6b7b56a5e3d64fa238b45a0d9b1c6d7ba (patch)
tree3cef462eb8490f2a5db05561506cb936e9ebe7a1
downloadaur-perl-business-issn.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90fb2662ded6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-business-issn
+ pkgdesc = Work with International Standard Serial Numbers
+ pkgver = 0.91
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Business-ISSN
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/B/BD/BDFOY/Business-ISSN-0.91.tar.gz
+ md5sums = d1f609422d3a0ad5e301ae694d142fe4
+ sha512sums = 5a7d098feda97088b89b58313c2f05555a0c15f3220fa7bf6d77428e38cc25dc747671813ec64c67ed90ac0f29de4c6aaeb846d7ff41ba1e8e54b4a24c6adb31
+
+pkgname = perl-business-issn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3b5548d993c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-business-issn'
+pkgver='0.91'
+pkgrel='1'
+pkgdesc="Work with International Standard Serial Numbers"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/Business-ISSN'
+source=('http://search.cpan.org/CPAN/authors/id/B/BD/BDFOY/Business-ISSN-0.91.tar.gz')
+md5sums=('d1f609422d3a0ad5e301ae694d142fe4')
+sha512sums=('5a7d098feda97088b89b58313c2f05555a0c15f3220fa7bf6d77428e38cc25dc747671813ec64c67ed90ac0f29de4c6aaeb846d7ff41ba1e8e54b4a24c6adb31')
+_distdir="Business-ISSN-0.91"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: