summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2019-08-20 11:41:44 +0300
committerAnton Leontiev2019-08-20 11:41:44 +0300
commit34b16c6bd3c38464af12978feabca09196ee2c8a (patch)
treedc718bd2bd35a89f0c6d46bbe2246729e7169041
parent78f808be96770e4702190e22039ad3206934d63a (diff)
downloadaur-perl-cgi-application-plugin-dbh.tar.gz
Sanitize environment and fix command to remove .packlist and perllocal.pod
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
-rw-r--r--PKGBUILD.tt12
3 files changed, 26 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 174be609562c..60c42d55f6bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = perl-cgi-application-plugin-dbh
pkgdesc = Perl package for easy DBI access from CGI::Application
pkgver = 4.04
- pkgrel = 1
- url = http://search.cpan.org/dist/CGI-Application-Plugin-DBH
+ pkgrel = 2
+ url = https://metacpan.org/release/CGI-Application-Plugin-DBH
arch = any
license = PerlArtistic
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index f46a2fff7597..3d057762f232 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# CPAN Name : CGI::Application::Plugin::DBH
-# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.28
+# Contributor: Anton Leontiev <scileont /at/ gmail.com>
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname=perl-cgi-application-plugin-dbh
pkgver=4.04
-pkgrel=1
+pkgrel=2
pkgdesc='Perl package for easy DBI access from CGI::Application'
arch=('any')
-url='http://search.cpan.org/dist/CGI-Application-Plugin-DBH'
+url='https://metacpan.org/release/CGI-Application-Plugin-DBH'
license=('PerlArtistic' 'GPL')
depends=('perl>=5.10.1' 'perl-cgi-application' 'perl-dbi')
checkdepends=('perl-test-mockobject>=1.20120301' 'perl-dbd-mock>=0.11')
@@ -15,19 +15,27 @@ source=(http://search.cpan.org/CPAN/authors/id/F/FR/FREW/CGI-Application-Plugin-
options=(!emptydirs)
md5sums=('da6d7bc3b084624fffadd34834f71f77')
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps"
+}
+
build() {
cd CGI-Application-Plugin-DBH-4.04
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ sanitize
+ perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
cd CGI-Application-Plugin-DBH-4.04
+ sanitize
make test
}
package() {
cd CGI-Application-Plugin-DBH-4.04
+ sanitize
make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index af33fc3065b5..e1c575b62074 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -15,19 +15,27 @@ source=([% source %])
options=(!emptydirs)
md5sums=('[% md5sums %]')
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps"
+}
+
build() {
cd [% distdir %]
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ sanitize
+ perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
cd [% distdir %]
+ sanitize
make test
}
package() {
cd [% distdir %]
+ sanitize
make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}