summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2016-03-26 17:55:06 -0600
committerJohn D Jones III2016-03-26 17:55:06 -0600
commit91dc0dad3ae15f21ec19ed98cd31126443398d5d (patch)
tree43133190feaad125ab57140e37283901939e58ae
parent3fabc420e417cb25ed6be08e4dbe711034ce066a (diff)
downloadaur-perl-cgi-application-plugin-requiressl.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD55
2 files changed, 47 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd7070d0dfc9..5ecbe5795e47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Mar 26 23:54:41 UTC 2016
pkgbase = perl-cgi-application-plugin-requiressl
- pkgdesc = CGI::Application::Plugin::RequireSSL - Force SSL in specified pages or modules
+ pkgdesc = Force SSL in specified pages or modules
pkgver = 0.04
pkgrel = 1
- url = http://search.cpan.org/~dhorne/CGI-Application-Plugin-RequireSSL-0.04/
+ url = https://metacpan.org/release/CGI-Application-Plugin-RequireSSL
arch = any
- license = unknown
- depends = perl>=5.10.0
- depends = perl-cgi-application
+ license = PerlArtistic
+ license = GPL
+ depends = perl-cgi-application>=4.01
options = !emptydirs
- source = http://cpan.perl.org/modules/by-authors/id/D/DH/DHORNE/CGI-Application-Plugin-RequireSSL-0.04.tar.gz
+ source = http://search.cpan.org/CPAN/authors/id/D/DH/DHORNE/CGI-Application-Plugin-RequireSSL-0.04.tar.gz
md5sums = ffa4fbe3014ded658dc796aafc01a5f8
+ sha512sums = 81282eeb71f55038eec2e936d906c5312dedfdbcb6e5198f73fd6caf1022b56bafc3c0bb6f797ffeef0912a085374e7b5fac1ede658ea3258b3147a3f3cceae7
pkgname = perl-cgi-application-plugin-requiressl
diff --git a/PKGBUILD b/PKGBUILD
index 1c496658a927..30b296001616 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,49 @@
-# Maintainer: Jonne Haß <me@mrzyx.de>
-_author="dhorne"
-_perlmod="CGI-Application-Plugin-RequireSSL"
-pkgname=perl-cgi-application-plugin-requiressl
-pkgver=0.04
-pkgrel=1
-pkgdesc="CGI::Application::Plugin::RequireSSL - Force SSL in specified pages or modules"
+# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-cgi-application-plugin-requiressl'
+pkgver='0.04'
+pkgrel='1'
+pkgdesc="Force SSL in specified pages or modules"
arch=('any')
-url="http://search.cpan.org/~$_author/$_perlmod-$pkgver/"
-license=('unknown')
-depends=('perl>=5.10.0' 'perl-cgi-application')
-options=(!emptydirs)
-source=(http://cpan.perl.org/modules/by-authors/id/D/DH/DHORNE/$_perlmod-$pkgver.tar.gz)
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-cgi-application>=4.01')
+makedepends=()
+url='https://metacpan.org/release/CGI-Application-Plugin-RequireSSL'
+source=('http://search.cpan.org/CPAN/authors/id/D/DH/DHORNE/CGI-Application-Plugin-RequireSSL-0.04.tar.gz')
md5sums=('ffa4fbe3014ded658dc796aafc01a5f8')
+sha512sums=('81282eeb71f55038eec2e936d906c5312dedfdbcb6e5198f73fd6caf1022b56bafc3c0bb6f797ffeef0912a085374e7b5fac1ede658ea3258b3147a3f3cceae7')
+_distdir="CGI-Application-Plugin-RequireSSL-0.04"
build() {
- cd "$srcdir/$_perlmod-$pkgver"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
}
package() {
- cd "$srcdir/$_perlmod-$pkgver"
- make install DESTDIR="$pkgdir/"
+ cd "$srcdir/$_distdir"
+ make install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
# vim:set ts=2 sw=2 et: