summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2019-08-22 09:51:36 +0300
committerAnton Leontiev2019-08-22 09:51:36 +0300
commitf7bbdc1b4480361b6700568f6e4c14c847d954a8 (patch)
tree70b029397ca89e2b4f500633764c73b2680fbed3
parentd1b59af863c95451bce6147bdfd7b8e9c1152809 (diff)
downloadaur-perl-cgi-cookie-splitter.tar.gz
Sanitize environment and fix command to remove .packlist and perllocal.pod
-rw-r--r--PKGBUILD.tt12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index 68f2a0dcfdea..c17a87b81320 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -15,19 +15,27 @@ source=([% source %])
options=(!emptydirs)
md5sums=('[% md5sums %]')
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps"
+}
+
build() {
cd [% distdir %]
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ sanitize
+ perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
cd [% distdir %]
+ sanitize
make test
}
package() {
cd [% distdir %]
+ sanitize
make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}