summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorint2017-10-16 00:36:42 +0200
committerint2017-10-16 00:36:42 +0200
commitbc34daab60e3aa25fef61d3e3d26830d6d8351db (patch)
treebec716e3b4bf7e567c6c7e335ed8ba94f1725d8b
parent0aab9ae7901e8b89faf973c4e95df210f67218a6 (diff)
downloadaur-perl-class-returnvalue.tar.gz
Added Bugfix.
Fixed "Can't locate inc/Module/Install.pm in @INC", see https://rt.cpan.org/Public/Bug/Display.html?id=120825 for details. Different Perl/CPAN-module, but same problem.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24a8e4020edd..1e93068ead34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = perl-class-returnvalue
pkgdesc = Perl/CPAN Module Class::ReturnValue: A smart return value object
pkgver = 0.55
- pkgrel = 4
+ pkgrel = 5
url = https://metacpan.org/release/Class-ReturnValue
arch = any
license = PerlArtistic
diff --git a/PKGBUILD b/PKGBUILD
index 1a564b96614f..b6b74d5a8c1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='perl-class-returnvalue'
pkgver='0.55'
-pkgrel='4'
+pkgrel='5'
pkgdesc="Perl/CPAN Module Class::ReturnValue: A smart return value object"
arch=('any')
license=('PerlArtistic' 'GPL')
@@ -17,6 +17,21 @@ md5sums=('047fbbcfd90d5c399a1feba55781329e')
sha512sums=('27aecf99a7db6c943c5300048a4e51aa7646fc83d2a6494f24a68fc76755a9e565099fa830e7f745b76c9ab1b2a8c5ac2a90cf3b22f250245413923bf03b315c')
_distdir="Class-ReturnValue-0.55"
+prepare() {
+ cd "$srcdir/$_distdir"
+
+ # Patch Makefile.PL
+ # by adding "use lib '.';" before "use inc::Module::Install".
+ # Maybe a real patch-file would be better.
+ #
+ # This fixes the "Can't locate inc/Module/Install.pm in @INC"-error,
+ # which isn't upstream yet, when doing "make".
+ # See https://rt.cpan.org/Public/Bug/Display.html?id=120825
+ # for details on this problem (but for a different Perl/CPAN-module).
+ #
+ sed -i "s/use inc::Module::Install/use lib '.';\nuse inc::Module::Install/" Makefile.PL
+}
+
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
PERL_AUTOINSTALL=--skipdeps \