summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJanne Heß2017-09-30 22:03:03 +0200
committerJanne Heß2017-09-30 22:03:03 +0200
commitdf9f56232c31a5d5efa92b187ff79496e5a8a90c (patch)
tree6b7a43ff5f935ce9426737237119972508a6155f
downloadaur-perl-config-auto.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD26
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c2f34a693e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Sep 30 20:01:47 UTC 2017
+pkgbase = perl-config-auto
+ pkgdesc = Magical config file parser
+ pkgver = 0.44
+ pkgrel = 1
+ url = http://search.cpan.org/~bingos/Config-Auto-0.44/lib/Config/Auto.pm
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ source = http://search.cpan.org/CPAN/authors/id/B/BI/BINGOS/Config-Auto-0.44.tar.gz
+ sha512sums = 8102100c6c8fb0f644aecf429c265a3ed502497576cfbcbb011697a0eced072ae8e912eec99dc74796382a394036ade88df7b93d1a2882cd381ae789c71196f9
+
+pkgname = perl-config-auto
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..00054c32125f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg/
+/src/
+*.tar
+*.xz
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f83e32d1bc4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Janne Heß <jannehess@gmail.com>
+
+pkgname=perl-config-auto
+pkgver=0.44
+pkgrel=1
+pkgdesc='Magical config file parser'
+license=('GPL' 'PerlArtistic')
+url="http://search.cpan.org/~bingos/Config-Auto-${pkgver}/lib/Config/Auto.pm"
+depends=('perl')
+source=("http://search.cpan.org/CPAN/authors/id/B/BI/BINGOS/Config-Auto-${pkgver}.tar.gz")
+sha512sums=('8102100c6c8fb0f644aecf429c265a3ed502497576cfbcbb011697a0eced072ae8e912eec99dc74796382a394036ade88df7b93d1a2882cd381ae789c71196f9')
+arch=('any')
+
+build() {
+ cd "${srcdir}/Config-Auto-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+package() {
+ cd "${srcdir}/Config-Auto-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="${pkgdir}"
+}