summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorint2017-10-17 22:28:31 +0200
committerint2017-10-17 22:28:31 +0200
commitb1ef7104ea4d66e395ede92bc2224c871267316b (patch)
treeee98f862f8f661eabb6ebe857b783c1026e29314
downloadaur-perl-convert-basen.tar.gz
Perl/CPAN Module Convert::BaseN
This is one of the (optional) perl-dependencies of Koha: https://koha-community.org/ Start "./koha_perl_deps.pl -a" after downloading and unpacking the koha-tarball for a list of all packages (required and optional). This is with the cpan2aur-bugfix, see https://rt.cpan.org/Public/Bug/Display.html?id=123153 for details.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b108a75e824
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-convert-basen
+ pkgdesc = Perl/CPAN Module Convert::BaseN: encoding and decoding of base{2,4,8,16,32,64} strings
+ pkgver = 0.01
+ pkgrel = 1
+ url = https://metacpan.org/release/Convert-BaseN
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/D/DA/DANKOGAI/Convert-BaseN-0.01.tar.gz
+ md5sums = 4744bcb7692d81d3bbe777f96727f4c4
+ sha512sums = e0a69f928772c4868e0cb310e9b4d6a5dac5919cea3cbf68bef46601fe2f1f0ce31d5974ab60d2eb6043888af61912119e3ae630b0428d51c212e1f12a834a0d
+
+pkgname = perl-convert-basen
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..848bcd7eb3a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer : int <int [ate] arcor [dot] de>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-convert-basen'
+pkgver='0.01'
+pkgrel='1'
+pkgdesc="Perl/CPAN Module Convert::BaseN: encoding and decoding of base{2,4,8,16,32,64} strings"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='https://metacpan.org/release/Convert-BaseN'
+source=("http://search.cpan.org/CPAN/authors/id/D/DA/DANKOGAI/Convert-BaseN-$pkgver.tar.gz")
+md5sums=('4744bcb7692d81d3bbe777f96727f4c4')
+sha512sums=('e0a69f928772c4868e0cb310e9b4d6a5dac5919cea3cbf68bef46601fe2f1f0ce31d5974ab60d2eb6043888af61912119e3ae630b0428d51c212e1f12a834a0d')
+_distdir="Convert-BaseN-$pkgver"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" "(" -name .packlist -o -name perllocal.pod ")" -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: