summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuri Grabowski2015-07-18 19:39:03 +0200
committerJuri Grabowski2015-07-18 19:39:03 +0200
commit11768fdcd5ad2e931a93f06b965f79db97436816 (patch)
tree144e6bbf3baa578b8241e95cb156c6e72da642a0
downloadaur-perl-datetime-format-xsd.tar.gz
0.2
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77efa09e0a8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = perl-datetime-format-xsd
+ pkgdesc = Parse and Format DateTimes using XSD
+ pkgver = 0.2
+ pkgrel = 0
+ url = http://search.cpan.org/~druoso/DateTime-Format-XSD-0.2/lib/DateTime/Format/XSD.pm
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-datetime>=0.72
+ depends = perl-datetime-locale>=0.45
+ depends = perl-datetime-timezone>=0.79
+ depends = perl-params-validate>=0.64
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/D/DR/DRUOSO/DateTime-Format-XSD-0.2.tar.gz
+ md5sums = 8b78130ef8630d24935c8f1df3467a98
+
+pkgname = perl-datetime-format-xsd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5db202e2192b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 123966 2014-12-16 12:43:39Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Caleb Cushing <xenoterracide@gmail.com>
+
+pkgname=perl-datetime-format-xsd
+pkgver=0.2
+pkgrel=0
+pkgdesc="Parse and Format DateTimes using XSD"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-datetime>=0.72' 'perl-datetime-locale>=0.45'
+ 'perl-datetime-timezone>=0.79' 'perl-params-validate>=0.64')
+url="http://search.cpan.org/~druoso/DateTime-Format-XSD-0.2/lib/DateTime/Format/XSD.pm"
+source=("http://search.cpan.org/CPAN/authors/id/D/DR/DRUOSO/DateTime-Format-XSD-0.2.tar.gz")
+md5sums=('8b78130ef8630d24935c8f1df3467a98')
+
+build() {
+ export PERL_MM_USE_DEFAULT=1
+ cd "${srcdir}/DateTime-Format-XSD-${pkgver}"
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "${srcdir}/DateTime-Format-XSD-${pkgver}"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}