summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2020-03-09 17:44:56 +0300
committerAnton Leontiev2020-03-09 17:44:56 +0300
commitb93946871f2cd21d65722430cab20ddc7ba8107c (patch)
tree22e12c6f6e0cfb658e1a455930c4863d1a10a789
parentfb6833a381afc96209c3fd4b46d577c538793fd5 (diff)
downloadaur-perl-dbm-deep.tar.gz
Update to v2.0016
This commit also fixes command to remove .packlist and perllocal.pod.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
-rw-r--r--PKGBUILD.tt4
3 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5de72ec39aa..7ba0c02f76b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = perl-dbm-deep
pkgdesc = A pure Perl multi-level hash/array DBM that supports transactions
- pkgver = 2.0012
+ pkgver = 2.0016
pkgrel = 1
url = https://metacpan.org/release/DBM-Deep
arch = any
license = PerlArtistic
license = GPL
+ checkdepends = perl-test-deep
+ checkdepends = perl-test-warn
+ checkdepends = perl-test-exception
makedepends = perl-module-build>=0.42
depends = perl
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/R/RK/RKINYON/DBM-Deep-2.0012.tar.gz
- md5sums = da911dada2c978ea6bd4d1bac4b4ba46
+ source = http://search.cpan.org/CPAN/authors/id/S/SP/SPROUT/DBM-Deep-2.0016.tar.gz
+ md5sums = cb8817ddd1fecc81ae2d47f812fd1f0e
pkgname = perl-dbm-deep
diff --git a/PKGBUILD b/PKGBUILD
index 1f0469c6d991..143c28033d90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# CPAN Name : DBM::Deep
-# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.30
+# Contributor: Anton Leontiev <scileont /at/ gmail.com>
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname=perl-dbm-deep
-pkgver=2.0012
+pkgver=2.0016
pkgrel=1
pkgdesc='A pure Perl multi-level hash/array DBM that supports transactions'
arch=('any')
url='https://metacpan.org/release/DBM-Deep'
license=('PerlArtistic' 'GPL')
depends=('perl')
-cheackdepends=('perl-test-deep' 'perl-test-warn' 'perl-test-exception')
+checkdepends=('perl-test-deep' 'perl-test-warn' 'perl-test-exception')
makedepends=('perl-module-build>=0.42')
-source=(http://search.cpan.org/CPAN/authors/id/R/RK/RKINYON/DBM-Deep-2.0012.tar.gz)
+source=(http://search.cpan.org/CPAN/authors/id/S/SP/SPROUT/DBM-Deep-2.0016.tar.gz)
options=(!emptydirs)
-md5sums=('da911dada2c978ea6bd4d1bac4b4ba46')
+md5sums=('cb8817ddd1fecc81ae2d47f812fd1f0e')
sanitize() {
unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
@@ -22,21 +22,21 @@ sanitize() {
}
build() {
- cd DBM-Deep-2.0012
+ cd DBM-Deep-2.0016
sanitize
perl Build.PL --installdirs vendor --destdir "$pkgdir"
perl Build
}
check() {
- cd DBM-Deep-2.0012
+ cd DBM-Deep-2.0016
sanitize
perl Build test
}
package() {
- cd DBM-Deep-2.0012
+ cd DBM-Deep-2.0016
sanitize
perl Build install
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index 253b4bba9083..f66ec78323c7 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -10,7 +10,7 @@ arch=('any')
url='[% url %]'
license=('PerlArtistic' 'GPL')
depends=('perl')
-cheackdepends=('perl-test-deep' 'perl-test-warn' 'perl-test-exception')
+checkdepends=('perl-test-deep' 'perl-test-warn' 'perl-test-exception')
makedepends=('perl-module-build>=0.42')
source=([% source %])
options=(!emptydirs)
@@ -38,5 +38,5 @@ package() {
cd [% distdir %]
sanitize
perl Build install
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}