summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDirk Langer2019-06-03 10:29:22 +0200
committerDirk Langer2019-06-03 10:29:22 +0200
commitfb577865222f0a8adcae83df4c086397a7885d28 (patch)
tree13475fbf73f56375d1369f0bf11f33fddbd3e92f
downloadaur-perl-encoding-handleutf8.tar.gz
initial version 0.004
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD49
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..846ab4237e57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = perl-encoding-handleutf8
+ pkgdesc = Fix the encoding for Perl value store (input) and general output (output) to a console or the web.
+ pkgver = 0.004
+ pkgrel = 1
+ url = https://metacpan.org/release/Encoding-HandleUtf8
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ checkdepends = perl-test-nowarnings>=0
+ checkdepends = perl-test-warn>=0
+ depends = perl-clone>=0
+ depends = perl-encoding-fixlatin>=0
+ depends = perl>=5.010
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/B/BU/BURNERSK/Encoding-HandleUtf8-0.004.tar.gz
+ md5sums = aa6e3a30828965b033c3654ddd3656cd
+ sha512sums = 678fcdffee7ab17100a45941b8a79f8d7095bf70796603430f721dd0097aeb8204eb4c8cdfc3e8df0249e1d6b4fc4ba14429f099459591c1c2af7cbbf24dd6d6
+
+pkgname = perl-encoding-handleutf8
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60336eaa7793
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Contributor: ordoban <dirk.langer@vvovgonik.de>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-encoding-handleutf8'
+pkgver='0.004'
+pkgrel='1'
+pkgdesc="Fix the encoding for Perl value store (input) and general output (output) to a console or the web."
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-clone>=0' 'perl-encoding-fixlatin>=0' 'perl>=5.010')
+makedepends=()
+checkdepends=('perl-test-nowarnings>=0' 'perl-test-warn>=0')
+url='https://metacpan.org/release/Encoding-HandleUtf8'
+source=('http://search.cpan.org/CPAN/authors/id/B/BU/BURNERSK/Encoding-HandleUtf8-0.004.tar.gz')
+md5sums=('aa6e3a30828965b033c3654ddd3656cd')
+sha512sums=('678fcdffee7ab17100a45941b8a79f8d7095bf70796603430f721dd0097aeb8204eb4c8cdfc3e8df0249e1d6b4fc4ba14429f099459591c1c2af7cbbf24dd6d6')
+_distdir="Encoding-HandleUtf8-0.004"
+
+build() {
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: