summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 14:54:20 -0600
committerJohn D Jones III2015-06-16 14:54:20 -0600
commit396c1bac5eb6d9a446594ebfac14603f69933505 (patch)
tree3103b2ac5c5d0f2fffa16062e0e1d0f10ec8a387
downloadaur-perl-file-find-rule.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a58f0d73b55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-file-find-rule
+ pkgdesc = Alternative interface to File::Find
+ pkgver = 0.33
+ pkgrel = 3
+ url = http://search.mcpan.org/dist/File-Find-Rule
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-number-compare
+ depends = perl-text-glob>=0.07
+ options = !emptydirs
+ source = http://search.mcpan.org/CPAN/authors/id/R/RC/RCLAMP/File-Find-Rule-0.33.tar.gz
+ md5sums = 92c6cb88549c30f5665e39bf80f3d704
+ sha512sums = 287537a39e4ceeef6388dcf27c6b10fd7aceae7ab55b27f6acd608687ae695f964703e5b2ea2efbb57f7e5a6b658d7637fef5e87695fe39ae3222f8c7808ff31
+
+pkgname = perl-file-find-rule
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..694af96f7eea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.29
+
+pkgname='perl-file-find-rule'
+pkgver='0.33'
+pkgrel='3'
+pkgdesc="Alternative interface to File::Find"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-number-compare' 'perl-text-glob>=0.07')
+makedepends=()
+url='http://search.mcpan.org/dist/File-Find-Rule'
+source=('http://search.mcpan.org/CPAN/authors/id/R/RC/RCLAMP/File-Find-Rule-0.33.tar.gz')
+md5sums=('92c6cb88549c30f5665e39bf80f3d704')
+sha512sums=('287537a39e4ceeef6388dcf27c6b10fd7aceae7ab55b27f6acd608687ae695f964703e5b2ea2efbb57f7e5a6b658d7637fef5e87695fe39ae3222f8c7808ff31')
+_distdir="File-Find-Rule-0.33"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: