summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCpanBot2023-11-13 22:54:25 +0000
committerCpanBot2023-11-13 22:54:25 +0000
commitfb7bdf685c79caaf31e36d684e2ba9c24cdcb27e (patch)
treeab0639064366e567d1f17a37027704b4084a024f
parentd62c8c3369443deddadf5732bbad8d090c1da5bd (diff)
downloadaur-perl-geo-ipfree.tar.gz
Converted 'Geo::IPfree' with cpan2aur2git
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD58
2 files changed, 52 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8170066b2c7c..e4be8ee1b1ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
-# Generated by mksrcinfo v8
-# Wed Sep 14 17:23:59 UTC 2016
pkgbase = perl-geo-ipfree
- pkgdesc = Look up country of IP Address. This module make this off-line and the DB of IPs is free & small.
- pkgver = 1.151940
+ pkgdesc = Geo::IPfree - Look up the country of an IPv4 address
+ pkgver = 1.160000
pkgrel = 1
- url = http://search.cpan.org/~bricas/Geo-IPfree
+ url = https://metacpan.org/release/Geo-IPfree
arch = any
- license = GPL
license = PerlArtistic
+ license = GPL
+ checkdepends = perl-test2-plugin-nowarnings>=0
+ checkdepends = perl-test2-suite>=0
+ checkdepends = perl-test2-tools-explain>=0
+ depends = perl>=5.008
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/B/BR/BRICAS/Geo-IPfree-1.151940.tar.gz
- sha256sums = ae8d67f4f7e999ee0190ca112045e207ef019fe5eda8b634ef2479f34d8f6251
+ source = http://search.cpan.org/CPAN/authors/id/A/AT/ATOOMIC/Geo-IPfree-1.160000.tar.gz
+ md5sums = 6784e81f27c579e8d1f670674137684b
+ sha512sums = 7193d9c1895f99d41b4d15c1f11e8deeb729f4143eeb1a0b7aa8a2fe8e92e281c2208a5756f7d3da14983fd27fb9631e4cf897a967f04285e7b7394ca26d4945
pkgname = perl-geo-ipfree
-
diff --git a/PKGBUILD b/PKGBUILD
index 04d6df106643..d0649dd51acf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,50 @@
-# Maintainer: Arthur Țițeică arthur.titeica/gmail/com
-# Contributor: Pizon <pizon@pizon.org>
+# Contributor: CpanBot <cpanbot at sch bme hu>
+# Generator : CPANPLUS::Dist::Arch 1.32
-pkgname=perl-geo-ipfree
-pkgver=1.151940
-pkgrel=1
-pkgdesc="Look up country of IP Address. This module make this off-line and the DB of IPs is free & small."
+pkgname='perl-geo-ipfree'
+pkgver='1.160000'
+pkgrel='1'
+pkgdesc="Geo::IPfree - Look up the country of an IPv4 address"
arch=('any')
-url="http://search.cpan.org/~bricas/Geo-IPfree"
-license=('GPL' 'PerlArtistic')
+license=('PerlArtistic' 'GPL')
options=('!emptydirs')
-source=(http://search.cpan.org/CPAN/authors/id/B/BR/BRICAS/Geo-IPfree-$pkgver.tar.gz)
-sha256sums=('ae8d67f4f7e999ee0190ca112045e207ef019fe5eda8b634ef2479f34d8f6251')
+depends=('perl>=5.008')
+makedepends=()
+checkdepends=('perl-test2-plugin-nowarnings>=0' 'perl-test2-suite>=0' 'perl-test2-tools-explain>=0')
+url='https://metacpan.org/release/Geo-IPfree'
+source=('http://search.cpan.org/CPAN/authors/id/A/AT/ATOOMIC/Geo-IPfree-1.160000.tar.gz')
+md5sums=('6784e81f27c579e8d1f670674137684b')
+sha512sums=('7193d9c1895f99d41b4d15c1f11e8deeb729f4143eeb1a0b7aa8a2fe8e92e281c2208a5756f7d3da14983fd27fb9631e4cf897a967f04285e7b7394ca26d4945')
+_distdir="Geo-IPfree-1.160000"
build() {
- cd "$srcdir/Geo-IPfree-$pkgver"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
}
package() {
- cd "$srcdir/Geo-IPfree-$pkgver"
- make install DESTDIR="$pkgdir/"
- find "$pkgdir/" -name '.packlist' -delete
- find "$pkgdir/" -name '*.pod' -delete
+ cd "$srcdir/$_distdir"
+ make install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: