summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThiago L. A. Miller2018-08-28 02:53:15 -0300
committerThiago L. A. Miller2018-09-05 02:42:54 -0300
commit4419fd189ebe5c97356fe73d0b50fe5823eba74f (patch)
tree41428269ba46c05a1f8362318e29c104405700bc
downloadaur-perl-hook-afterruntime.tar.gz
First commit $Hook::AfterRuntime::VERSION = 0.006
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14c839349ff8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-hook-afterruntime
+ pkgdesc = Run code at the end of the compiling scope's runtime
+ pkgver = 0.006
+ pkgrel = 1
+ url = https://metacpan.org/release/Hook-AfterRuntime
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl>=5.006
+ depends = perl-b-hooks-parser>=0.09
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/P/PT/PTC/Hook-AfterRuntime-0.006.tar.gz
+ md5sums = 2e0b1b7617e158aa34a711ec57ae935b
+
+pkgname = perl-hook-afterruntime
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e20245338b32
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9cca8035dcf8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Thiago L. A. Miller <thiago_leisrael@hotmail.com>
+_distname=Hook-AfterRuntime
+pkgname=perl-hook-afterruntime
+pkgver=0.006
+pkgrel=1
+pkgdesc="Run code at the end of the compiling scope's runtime"
+arch=('any')
+url="https://metacpan.org/release/$_distname"
+license=('PerlArtistic' 'GPL')
+depends=('perl>=5.006' 'perl-b-hooks-parser>=0.09')
+makedepends=()
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/P/PT/PTC/$_distname-$pkgver.tar.gz")
+md5sums=('2e0b1b7617e158aa34a711ec57ae935b')
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$_distname-$pkgver"
+ /usr/bin/perl Build.PL
+ /usr/bin/perl Build
+ )
+}
+
+check() {
+ cd "$_distname-$pkgver"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ /usr/bin/perl Build test
+ )
+}
+
+package() {
+ cd "$_distname-$pkgver"
+ /usr/bin/perl Build install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: