summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2016-04-18 17:13:05 -0600
committerJohn D Jones III2016-04-18 17:13:05 -0600
commit83d92cab6dfb65181e9d273921ccacabfe054def (patch)
tree40c7a715b8ffbe62da81fc7ffc9f6d175a03362e
parent5e13c3a94321a9a37ca1caed9b78fb0610917b4f (diff)
downloadaur-perl-html-stripscripts.tar.gz
Add patch to make this compile
-rw-r--r--.SRCINFO7
-rw-r--r--HTML-StripScripts-1.05-Fix-typo-in-regex.patch12
-rw-r--r--PKGBUILD16
3 files changed, 27 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fad52c2e9d85..2bffb320ae13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Apr 18 23:12:32 UTC 2016
pkgbase = perl-html-stripscripts
pkgdesc = Strip scripting constructs out of HTML
pkgver = 1.05
pkgrel = 1
- url = http://search.cpan.org/dist/HTML-StripScripts
+ url = https://metacpan.org/release/HTML-StripScripts
arch = any
license = PerlArtistic
license = GPL
depends = perl
options = !emptydirs
source = http://search.cpan.org/CPAN/authors/id/D/DR/DRTECH/HTML-StripScripts-1.05.tar.gz
+ source = HTML-StripScripts-1.05-Fix-typo-in-regex.patch
md5sums = e8c51fbfda69efaf94c2937084d2458f
- sha512sums = e9de1a05721fa74b90168ef36596c4d32d5af365258f1a8b363ac7a2e2f15181e67cbadde1c1dcae1225b6d2850589fa14e252134cf799b84bf506f55f5e050d
+ md5sums = 9d9adc755b19118d4c3b187ee396c33c
pkgname = perl-html-stripscripts
diff --git a/HTML-StripScripts-1.05-Fix-typo-in-regex.patch b/HTML-StripScripts-1.05-Fix-typo-in-regex.patch
new file mode 100644
index 000000000000..a2c4463599b3
--- /dev/null
+++ b/HTML-StripScripts-1.05-Fix-typo-in-regex.patch
@@ -0,0 +1,12 @@
+diff -up HTML-StripScripts-1.05/StripScripts.pm.orig HTML-StripScripts-1.05/StripScripts.pm
+--- HTML-StripScripts-1.05/StripScripts.pm.orig 2015-05-05 09:12:33.495920443 +0200
++++ HTML-StripScripts-1.05/StripScripts.pm 2015-05-05 09:53:33.099908066 +0200
+@@ -1630,7 +1630,7 @@ size or length.
+
+ sub _hss_attval_size {
+ $_[3]
+- =~ /^\s*([+-]?\d{1,20}(?:\.\d{1,20)?)\s*((?:\%|\*|ex|px|pc|cm|mm|in|pt|em)?)\s*$/i
++ =~ /^\s*([+-]?\d{1,20}(?:\.\d{1,20})?)\s*((?:\%|\*|ex|px|pc|cm|mm|in|pt|em)?)\s*$/i
+ ? lc "$1$2"
+ : undef;
+ }
diff --git a/PKGBUILD b/PKGBUILD
index 1d732e4d9069..6cfbc7837f80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
-# Generator : CPANPLUS::Dist::Arch 1.25
+# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname='perl-html-stripscripts'
pkgver='1.05'
@@ -10,10 +10,13 @@ license=('PerlArtistic' 'GPL')
options=('!emptydirs')
depends=('perl')
makedepends=()
-url='http://search.cpan.org/dist/HTML-StripScripts'
-source=('http://search.cpan.org/CPAN/authors/id/D/DR/DRTECH/HTML-StripScripts-1.05.tar.gz')
-md5sums=('e8c51fbfda69efaf94c2937084d2458f')
-sha512sums=('e9de1a05721fa74b90168ef36596c4d32d5af365258f1a8b363ac7a2e2f15181e67cbadde1c1dcae1225b6d2850589fa14e252134cf799b84bf506f55f5e050d')
+url='https://metacpan.org/release/HTML-StripScripts'
+source=(
+ 'http://search.cpan.org/CPAN/authors/id/D/DR/DRTECH/HTML-StripScripts-1.05.tar.gz'
+ 'HTML-StripScripts-1.05-Fix-typo-in-regex.patch')
+md5sums=(
+ 'e8c51fbfda69efaf94c2937084d2458f'
+ '9d9adc755b19118d4c3b187ee396c33c')
_distdir="HTML-StripScripts-1.05"
build() {
@@ -24,6 +27,7 @@ build() {
MODULEBUILDRC=/dev/null
cd "$srcdir/$_distdir"
+ patch -Np1 -i ../HTML-StripScripts-1.05-Fix-typo-in-regex.patch
/usr/bin/perl Makefile.PL
make
)