summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Göbel2019-02-27 15:51:32 +0100
committerStefan Göbel2019-02-27 15:51:32 +0100
commit313d416102257a6fc54d2fc795ce81674424cde3 (patch)
tree65a5f48963565458eef6a4bdb4364ffb5db316e8
downloadaur-perl-pod-spell-commonmistakes.tar.gz
initial commit: perl-test-pod-spelling-commonmistakes 1.002-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD48
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3db7f9a401f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = perl-pod-spell-commonmistakes
+ pkgdesc = Catches common typos in Pod.
+ pkgver = 1.002
+ pkgrel = 1
+ url = https://metacpan.org/release/Pod-Spell-CommonMistakes
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ makedepends = perl-module-build-tiny
+ depends = perl
+ depends = perl-io-stringy
+ depends = perl-pod-spell
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/A/AP/APOCAL/Pod-Spell-CommonMistakes-1.002.tar.gz
+ sha256sums = 2ba9ea76c049daf892ba2bdd85a07099a33be315876f55ed33a644d575324432
+
+pkgname = perl-pod-spell-commonmistakes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..258935ec4898
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Stefan Göbel <aur —at— subtype —dot— de>
+
+pkgname='perl-pod-spell-commonmistakes'
+_module='Pod-Spell-CommonMistakes'
+_author='A/AP/APOCAL'
+pkgver='1.002'
+pkgrel='1'
+pkgdesc='Catches common typos in Pod.'
+arch=('any')
+url="https://metacpan.org/release/$_module"
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl' 'perl-io-stringy' 'perl-pod-spell')
+makedepends=('perl-module-build-tiny')
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_module-$pkgver.tar.gz")
+sha256sums=('2ba9ea76c049daf892ba2bdd85a07099a33be315876f55ed33a644d575324432')
+
+build() {
+ (
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT='1' PERL_AUTOINSTALL='--skipdeps'
+ cd "$_module-$pkgver"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ (
+ cd "$_module-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT='1'
+ make test
+ )
+}
+
+package() {
+ (
+ cd "$_module-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS='vendor' DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -delete
+ find "$pkgdir" -name perllocal.pod -delete
+ find "$pkgdir" -type d -empty -delete
+ )
+}
+
+#:indentSize=3:tabSize=3:noTabs=true:mode=shellscript:maxLineLen=87: