summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 15:46:27 -0600
committerJohn D Jones III2015-06-16 15:46:27 -0600
commitf511206ca7492ec6ed383675e9a2a4bcbfa8c8dd (patch)
tree4b9efa721741027269b4a05599dd7d772a813d34
downloadaur-perl-pod-wordlist-hanekomu.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD51
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b12def9ac5f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = perl-pod-wordlist-hanekomu
+ pkgdesc = Add words for spell checking POD (DEPRECATED)
+ pkgver = 1.132680
+ pkgrel = 1
+ url = http://search.mcpan.org/dist/Pod-Wordlist-hanekomu
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ checkdepends = perl-test-spelling
+ checkdepends = perl-test-eol
+ depends = perl
+ options = !emptydirs
+ source = http://search.mcpan.org/CPAN/authors/id/D/DA/DAGOLDEN/Pod-Wordlist-hanekomu-1.132680.tar.gz
+ md5sums = e890599c15f0beaac5460e8586885247
+ sha512sums = ace1ef42a799608968754c780d218643493f47ade264c48e5d0a2800b31d75542ed1976afe13d8acb6a8c4b10d92b67d00638a0e0dd2647c91177eb43ae89124
+
+pkgname = perl-pod-wordlist-hanekomu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e83b20956ffa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.29
+
+pkgname='perl-pod-wordlist-hanekomu'
+pkgver='1.132680'
+pkgrel='1'
+pkgdesc="Add words for spell checking POD (DEPRECATED)"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+checkdepends=('perl-test-spelling' 'perl-test-eol')
+url='http://search.mcpan.org/dist/Pod-Wordlist-hanekomu'
+source=('http://search.mcpan.org/CPAN/authors/id/D/DA/DAGOLDEN/Pod-Wordlist-hanekomu-1.132680.tar.gz')
+md5sums=('e890599c15f0beaac5460e8586885247')
+sha512sums=('ace1ef42a799608968754c780d218643493f47ade264c48e5d0a2800b31d75542ed1976afe13d8acb6a8c4b10d92b67d00638a0e0dd2647c91177eb43ae89124')
+_distdir="Pod-Wordlist-hanekomu-1.132680"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: