summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Gallagher2023-10-04 11:18:05 +0100
committerMark Gallagher2023-10-04 11:18:05 +0100
commit43f02a8a9e739143b437914bf15bf17860420d52 (patch)
tree40c0d76759d12ce6d9236c9df9a8751f154c35ef
downloadaur-perl-session-token.tar.gz
perl-session-token 1.503
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..112cee2143be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-session-token
+ pkgdesc = Secure, efficient, simple random session token generation (From MetaCPAN distribution)
+ pkgver = 1.503
+ pkgrel = 1
+ url = https://metacpan.org/release/Session-Token
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ options = !emptydirs
+ options = purge
+ source = https://cpan.metacpan.org/authors/id/F/FR/FRACTAL/Session-Token-1.503.tar.gz
+ sha256sums = 32c3df96ef455c71870363acd950ddc4fbc848c594f4bc55b21b44cf979f79a1
+
+pkgname = perl-session-token
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d3bffd808323
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+Session-Token-*.tar.gz
+*.tar.xz
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7134f5147874
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Mark Gallagher <mark@fts.scot>
+pkgname=perl-session-token
+pkgver=1.503
+pkgrel=1
+pkgdesc='Secure, efficient, simple random session token generation (From MetaCPAN distribution)'
+_dist=Session-Token
+arch=('any')
+url="https://metacpan.org/release/$_dist"
+license=('GPL' 'PerlArtistic')
+depends=('perl')
+options=('!emptydirs' 'purge')
+source=("https://cpan.metacpan.org/authors/id/F/FR/FRACTAL/$_dist-$pkgver.tar.gz")
+sha256sums=(32c3df96ef455c71870363acd950ddc4fbc848c594f4bc55b21b44cf979f79a1)
+
+build() {
+ cd $_dist-$pkgver
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ cd $_dist-$pkgver
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
+package() {
+ cd $_dist-$pkgver
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+}