summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-08-14 22:10:21 +0300
committerCaleb Maclennan2021-08-14 22:13:33 +0300
commit3ef94f7abdcb8212877fdc59825373439cbbfd0c (patch)
tree099b589ac5bc864db3312cff81d13c2093402607
parent1f9202803b9fbc0c181c7d5af53a78c7a486aa20 (diff)
downloadaur-perl-test-most.tar.gz
Tidy up before more to [community]
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD48
2 files changed, 31 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2784ed52f987..201974fb20f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = perl-test-most
pkgdesc = Most commonly needed test functions and features
pkgver = 0.37
- pkgrel = 2
+ pkgrel = 3
url = https://metacpan.org/release/Test-Most
arch = any
- license = PerlArtistic
license = GPL
+ license = PerlArtistic
depends = perl
depends = perl-exception-class
depends = perl-test-deep
depends = perl-test-differences
depends = perl-test-exception
depends = perl-test-warn
- source = https://search.cpan.org/CPAN/authors/id/O/OV/OVID/Test-Most-0.37.tar.gz
+ options = !emptydirs
+ source = https://cpan.perl.org/modules/by-module/Test/Test-Most-0.37.tar.gz
sha256sums = 533370141eb9f18cf4ac380f6ded2ab57802a6e184008a80fd2304bfcc474fc7
pkgname = perl-test-most
diff --git a/PKGBUILD b/PKGBUILD
index 9e5fa37d638d..ae8449dfcfd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,43 @@
-# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Maintainer: Caleb Maclennan< caleb@alerque.com>
# Contributor: GPP <gergan@gmail.com>
-_distname=Test-Most
-pkgname=perl-${_distname,,}
+_cpan=Test-Most
+pkgname=perl-${_cpan,,}
pkgver=0.37
-pkgrel=2
+pkgrel=3
pkgdesc='Most commonly needed test functions and features'
arch=(any)
-url='https://metacpan.org/release/Test-Most'
-license=(PerlArtistic GPL)
-_perl_deps=(exception-class test-deep test-differences test-exception test-warn)
-depends=(perl "${_perl_deps[@]/#/perl-}")
-source=("https://search.cpan.org/CPAN/authors/id/O/OV/OVID/$_distname-$pkgver.tar.gz")
+url=https://metacpan.org/release/$_cpan
+license=(GPL PerlArtistic)
+_perldeps=(exception-class
+ test-deep
+ test-differences
+ test-exception
+ test-warn)
+depends=(perl
+ "${_perldeps[@]/#/perl-}")
+options=(!emptydirs)
+_archive="$_cpan-$pkgver"
+source=("https://cpan.perl.org/modules/by-module/${_cpan%-*}/$_archive.tar.gz")
sha256sums=('533370141eb9f18cf4ac380f6ded2ab57802a6e184008a80fd2304bfcc474fc7')
build() {
- cd "$_distname-$pkgver"
- export PERL_MM_USE_DEFAULT=1 PERL5LIB="" PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
- perl Makefile.PL
- make
+ cd "$_archive"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ perl Makefile.PL
+ make
}
check() {
- cd "$_distname-$pkgver"
- export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ cd "$_archive"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
make test
}
package() {
- cd "$_distname-$pkgver"
- make install
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd "$_archive"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
}