summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2016-03-26 18:02:31 -0600
committerJohn D Jones III2016-03-26 18:02:31 -0600
commit2c4e6f67acb0bb4fa0d4e727bf88d0fd2eaee1e8 (patch)
tree0503db20fb9c5666658c6998232156de6d521ef8
downloadaur-perl-test-regression.tar.gz
Add 0.07 PKGBUILD
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD49
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e1b4dae2c0a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun Mar 27 00:01:51 UTC 2016
+pkgbase = perl-test-regression
+ pkgdesc = Test library that can be run in two modes; one to generate outputs and a second to compare against them
+ pkgver = 0.07
+ pkgrel = 1
+ url = https://metacpan.org/release/Test-Regression
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-algorithm-diff
+ depends = perl-test-differences
+ depends = perl-test-mockobject
+ depends = perl-text-diff
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/M/MI/MITHALDU/Test-Regression-0.07.tar.gz
+ md5sums = 4b7137917d538e8763ed08ddd6a94606
+ sha512sums = 213ce430925d7ae19a70207a840109ffae1be0bdcf757422c3ccb0109b7b7dfa55d0c704d2886346cec3f38c59a7208b71e28626541fe7bfd982b623714c7115
+
+pkgname = perl-test-regression
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..511e15d562e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-test-regression'
+pkgver='0.07'
+pkgrel='1'
+pkgdesc="Test library that can be run in two modes; one to generate outputs and a second to compare against them"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-algorithm-diff' 'perl-test-differences' 'perl-test-mockobject' 'perl-text-diff')
+makedepends=()
+url='https://metacpan.org/release/Test-Regression'
+source=('http://search.cpan.org/CPAN/authors/id/M/MI/MITHALDU/Test-Regression-0.07.tar.gz')
+md5sums=('4b7137917d538e8763ed08ddd6a94606')
+sha512sums=('213ce430925d7ae19a70207a840109ffae1be0bdcf757422c3ccb0109b7b7dfa55d0c704d2886346cec3f38c59a7208b71e28626541fe7bfd982b623714c7115')
+_distdir="Test-Regression-0.07"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: