summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-12-28 06:14:32 -0700
committerJohn D Jones III2015-12-28 06:14:32 -0700
commitf16994805ccf687b09a2c6bf73e4453ad8500797 (patch)
tree54376d285208077bbde59fe093df4e9d1e278e94
parent4fe5d6c92230603a30bb66f010a86c15e720f20f (diff)
downloadaur-perl-unicode-collate.tar.gz
Update to perl-unicode-collate-1.14-1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD28
2 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8f86b16e092..8345dfd2ee2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = perl-unicode-collate
pkgdesc = Unicode Collation Algorithm
pkgver = 1.14
pkgrel = 1
- url = http://search.cpan.org/dist/Unicode-Collate
+ url = https://metacpan.org/release/Unicode-Collate
arch = i686
arch = x86_64
license = PerlArtistic
diff --git a/PKGBUILD b/PKGBUILD
index 088beda7deb4..5e0a892109fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,5 @@
-# Maintainer: jdarch <jda -dot- cloud -plus- archlinux -at- gmail -dot- com>
-# Contributor: Simon Hollingshead <me at [firstnamelastname] dot com>
-# Generator : CPANPLUS::Dist::Arch 1.25
+# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname='perl-unicode-collate'
pkgver='1.14'
@@ -10,12 +9,12 @@ arch=('i686' 'x86_64')
license=('PerlArtistic' 'GPL')
options=('!emptydirs')
depends=('perl')
-url='http://search.cpan.org/dist/Unicode-Collate'
-_ownname="Unicode-Collate-${pkgver}"
-
-source=("http://search.cpan.org/CPAN/authors/id/S/SA/SADAHIRO/${_ownname}.tar.gz")
+makedepends=()
+url='https://metacpan.org/release/Unicode-Collate'
+source=('http://search.cpan.org/CPAN/authors/id/S/SA/SADAHIRO/Unicode-Collate-1.14.tar.gz')
md5sums=('c486b31f87bfa3875883f3c9fad9fd99')
sha512sums=('a234c7ebb2f92886a68e39b681cb428bf99dd999f6a12ce137b132824072a07a60df3d26a4b147b2ec52c61df4f7c2fab5dad5cb40cce27fdff021cdf8208568')
+_distdir="Unicode-Collate-1.14"
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -24,21 +23,28 @@ build() {
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
MODULEBUILDRC=/dev/null
- cd "${srcdir}/${_ownname}"
+ cd "$srcdir/$_distdir"
/usr/bin/perl Makefile.PL
make
)
}
check() {
- cd "${srcdir}/${_ownname}"
+ cd "$srcdir/$_distdir"
( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
make test
)
}
package() {
- cd "${srcdir}/${_ownname}"
+ cd "$srcdir/$_distdir"
make install
- find "${pkgdir}" -name .packlist -o -name perllocal.pod -delete
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: