summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 16:16:51 -0600
committerJohn D Jones III2015-06-16 16:16:51 -0600
commitaa176947e2c10291ac30a8bf05b94f0b8d4fd2d1 (patch)
tree19bda8749abd3b98e4023cc0aa6dfbdca2c7ac19
downloadaur-perl-www-ipinfo.tar.gz
Initial import
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD51
3 files changed, 85 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..d8f2e5c573ec
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-www-ipinfo
+ pkgdesc = Returns your ip address and geolocation data using http://ipinfo.io
+ pkgver = 0.05
+ pkgrel = 1
+ url = http://search.mcpan.org/dist/WWW-ipinfo
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ checkdepends = perl-test-requiresinternet>=0.03
+ depends = perl-json
+ options = !emptydirs
+ source = http://search.mcpan.org/CPAN/authors/id/S/SI/SILLYMOOS/WWW-ipinfo-0.05.tar.gz
+ md5sums = e23df9a7bc02863813e69a0993da050b
+ sha512sums = 115754dc78cf9bfc09d270500c06c253c2d1f4186b10413cd4ed3bd75030b1bc952d36d18ab5acc30287fceaa3206b1b90bf9850ef727acb9c15115f39f08535
+
+pkgname = perl-www-ipinfo
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8f2e5c573ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-www-ipinfo
+ pkgdesc = Returns your ip address and geolocation data using http://ipinfo.io
+ pkgver = 0.05
+ pkgrel = 1
+ url = http://search.mcpan.org/dist/WWW-ipinfo
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ checkdepends = perl-test-requiresinternet>=0.03
+ depends = perl-json
+ options = !emptydirs
+ source = http://search.mcpan.org/CPAN/authors/id/S/SI/SILLYMOOS/WWW-ipinfo-0.05.tar.gz
+ md5sums = e23df9a7bc02863813e69a0993da050b
+ sha512sums = 115754dc78cf9bfc09d270500c06c253c2d1f4186b10413cd4ed3bd75030b1bc952d36d18ab5acc30287fceaa3206b1b90bf9850ef727acb9c15115f39f08535
+
+pkgname = perl-www-ipinfo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32ef57578c83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.28
+
+pkgname='perl-www-ipinfo'
+pkgver='0.05'
+pkgrel='1'
+pkgdesc="Returns your ip address and geolocation data using http://ipinfo.io"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-json')
+makedepends=()
+checkdepends=('perl-test-requiresinternet>=0.03')
+url='http://search.mcpan.org/dist/WWW-ipinfo'
+source=('http://search.mcpan.org/CPAN/authors/id/S/SI/SILLYMOOS/WWW-ipinfo-0.05.tar.gz')
+md5sums=('e23df9a7bc02863813e69a0993da050b')
+sha512sums=('115754dc78cf9bfc09d270500c06c253c2d1f4186b10413cd4ed3bd75030b1bc952d36d18ab5acc30287fceaa3206b1b90bf9850ef727acb9c15115f39f08535')
+_distdir="WWW-ipinfo-0.05"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: