summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfzerorubigd2016-03-16 19:44:09 +0330
committerfzerorubigd2016-03-16 19:44:09 +0330
commitb9da632a5ba7a63465a848845c47fa80ec5a8415 (patch)
tree5cdf54e02e872881e2c71c37c0ebf2124c2ef15f
downloadaur-b9da632a5ba7a63465a848845c47fa80ec5a8415.tar.gz
initial port from the git version
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD23
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f2410dbf91b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = pgcli
+ pkgdesc = a command line interface for Postgres with auto-completion and syntax highlighting
+ pkgver = 0.20.1
+ pkgrel = 1
+ url = http://pgcli.com/
+ arch = any
+ license = BSD
+ makedepends = python-distribute
+ depends = python
+ depends = python-sqlparse
+ depends = python-psycopg2
+ depends = python-click
+ depends = python-prompt_toolkit
+ depends = python-humanize
+ depends = python-configobj
+ depends = python-pgspecial
+ provides = pgcli
+ conflicts = pgcli-git
+ source = pgcli-0.20.1.zip::https://github.com/dbcli/pgcli/archive/v0.20.1.zip
+ md5sums = a2a8823993b472f0fae2a555229b6aca
+
+pkgname = pgcli
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0045cadbfc4a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+*.xz
+*.zip
+*.deb
+*.tar.gz
+*.tar.gz.asc
+*.tgz
+*.bz2
+/pkg
+/src
+*.gz
+rc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85fdd2696119
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: fzerorubigd <fzero@rubi.gd>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+
+pkgname=pgcli
+pkgver=0.20.1
+pkgrel=1
+pkgdesc="a command line interface for Postgres with auto-completion and syntax highlighting"
+url="http://pgcli.com/"
+arch=(any)
+license=('BSD')
+depends=('python' 'python-sqlparse' 'python-psycopg2' 'python-click' 'python-prompt_toolkit' 'python-humanize' 'python-configobj' 'python-pgspecial' )
+makedepends=('python-distribute')
+source=($pkgname-$pkgver.zip::https://github.com/dbcli/pgcli/archive/v0.20.1.zip)
+provides=('pgcli')
+conflicts=('pgcli-git')
+
+package() {
+ cd $srcdir/pgcli
+ python setup.py install --root=$pkgdir/ --optimize=1
+ echo "#!/usr/bin/bash" > $pkgdir/usr/bin/pgcli
+ echo "python -c 'import pgcli.main; pgcli.main.cli()' \"\$@\"" >> $pkgdir/usr/bin/pgcli
+}
+md5sums=('a2a8823993b472f0fae2a555229b6aca')