summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaultDon2016-08-09 12:04:09 -0700
committerSaultDon2016-08-09 12:04:09 -0700
commit2c781bfc6c298c871bc6b32530989379f6353ba5 (patch)
tree08db5497190a1f0ebe0651d4ba8c49dff4e5574a
parente23af1b2209299f8b41d36c588a1d662c79ccc91 (diff)
downloadaur-2c781bfc6c298c871bc6b32530989379f6353ba5.tar.gz
2.2.3-1 updated to current release
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bf63edc4a58..142deb346bb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = pgrouting
pkgdesc = Adds routing functionality to PostGIS/PostgreSQL
- pkgver = 2.1.0
+ pkgver = 2.2.3
pkgrel = 1
url = http://pgrouting.org/
arch = i686
arch = x86_64
license = GPL2
- makedepends = cmake>=2.8.8
+ makedepends = cmake
makedepends = boost
depends = postgis>=1.5
depends = gcc-libs
depends = cgal
- source = https://github.com/pgRouting/pgrouting/archive/pgrouting-2.1.0.tar.gz
- md5sums = c500b11d63893ba295ff6ef8ed255093
+ options = !makeflags
+ source = pgrouting-2.2.3.tar.gz::https://codeload.github.com/pgRouting/pgrouting/tar.gz/pgrouting-2.2.3
+ md5sums = 4f80700311cfab55bb37ac0705ebcc31
pkgname = pgrouting
diff --git a/PKGBUILD b/PKGBUILD
index 3ad9c6f41104..2e24578ff1a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,22 @@
# Contributor: Andre Klitzing <andre () incubo () de>
pkgname=pgrouting
-pkgver=2.1.0
+pkgver=2.2.3
pkgrel=1
pkgdesc="Adds routing functionality to PostGIS/PostgreSQL"
arch=('i686' 'x86_64')
url="http://pgrouting.org/"
license=('GPL2')
depends=('postgis>=1.5' 'gcc-libs' 'cgal')
-makedepends=('cmake>=2.8.8' 'boost')
-source=("https://github.com/pgRouting/pgrouting/archive/$pkgname-$pkgver.tar.gz")
-md5sums=('c500b11d63893ba295ff6ef8ed255093')
+makedepends=('cmake' 'boost')
+source=("$pkgname-$pkgver.tar.gz::https://codeload.github.com/pgRouting/$pkgname/tar.gz/$pkgname-$pkgver")
+md5sums=('4f80700311cfab55bb37ac0705ebcc31')
+options=(!makeflags)
prepare() {
cd $srcdir
mv $pkgname-$pkgname-$pkgver $pkgname-$pkgver
+
cd $pkgname-$pkgver
[[ -d build ]] || mkdir build
@@ -24,7 +26,7 @@ prepare() {
build() {
cd $pkgname-$pkgver/build
- cmake ../
+ cmake -L ../
make
}