summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaultDon2015-11-30 16:29:42 -0700
committerSaultDon2015-11-30 16:29:42 -0700
commite23af1b2209299f8b41d36c588a1d662c79ccc91 (patch)
tree4fe6e6aa46f1b9d8c8762eab2d874011f33fa43e
parent06a2e4318bf4e19dee72b838a05658f6b0ec6925 (diff)
downloadaur-e23af1b2209299f8b41d36c588a1d662c79ccc91.tar.gz
Update to 2.1.0-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
2 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01b0129a77f6..8bf63edc4a58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pgrouting
pkgdesc = Adds routing functionality to PostGIS/PostgreSQL
- pkgver = 2.0.0
- pkgrel = 8
+ pkgver = 2.1.0
+ pkgrel = 1
url = http://pgrouting.org/
arch = i686
arch = x86_64
@@ -11,8 +11,8 @@ pkgbase = pgrouting
depends = postgis>=1.5
depends = gcc-libs
depends = cgal
- source = pgrouting-2.0.0::git://github.com/pgRouting/pgrouting.git
- md5sums = SKIP
+ source = https://github.com/pgRouting/pgrouting/archive/pgrouting-2.1.0.tar.gz
+ md5sums = c500b11d63893ba295ff6ef8ed255093
pkgname = pgrouting
diff --git a/PKGBUILD b/PKGBUILD
index d609d2c96b54..3ad9c6f41104 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,34 @@
# Contributor: Andre Klitzing <andre () incubo () de>
pkgname=pgrouting
-pkgver=2.0.0
-pkgrel=8
+pkgver=2.1.0
+pkgrel=1
pkgdesc="Adds routing functionality to PostGIS/PostgreSQL"
arch=('i686' 'x86_64')
url="http://pgrouting.org/"
license=('GPL2')
depends=('postgis>=1.5' 'gcc-libs' 'cgal')
makedepends=('cmake>=2.8.8' 'boost')
-source=("$pkgname-$pkgver"::git://github.com/pgRouting/pgrouting.git)
-md5sums=('SKIP')
+source=("https://github.com/pgRouting/pgrouting/archive/$pkgname-$pkgver.tar.gz")
+md5sums=('c500b11d63893ba295ff6ef8ed255093')
+
+prepare() {
+ cd $srcdir
+ mv $pkgname-$pkgname-$pkgver $pkgname-$pkgver
+ cd $pkgname-$pkgver
+
+ [[ -d build ]] || mkdir build
+}
build() {
- cd "$srcdir/$pkgname-$pkgver"
- rm -rf build
- mkdir build
- cd build
+ cd $pkgname-$pkgver/build
- cmake ../ \
- -DWITH_DD=ON \
- -DWITH_TSP=ON
+ cmake ../
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver/build"
- make DESTDIR="$pkgdir/" install
+ cd $pkgname-$pkgver
+ make -C build DESTDIR="$pkgdir/" install
}