summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjoern Franke2024-11-08 00:49:09 +0100
committerBjoern Franke2024-11-08 00:49:09 +0100
commitda7cbd888ba668ee1a00a4c023620d1a32e9f11b (patch)
treef11b623a4b9dfd43b33fee28f70dba2814e14127
downloadaur-phanpy-bin.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c6f39402739
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = phanpy-bin
+ pkgdesc = A minimalistic opinionated Mastodon web client
+ pkgver = 2024.10.15.e3df9ff
+ pkgrel = 1
+ url = https://github.com/cheeaun/phanpy/
+ arch = x86_64
+ license = MIT
+ provides = phanpy
+ conflicts = phanpy
+ source = https://github.com/cheeaun/phanpy/releases/download/2024.10.15.e3df9ff/phanpy-dist.tar.gz
+ sha256sums = 2153f1ea7214f2c200e4aa081eb1351082ff59b7d9a92a73252d5fcbdceee68c
+
+pkgname = phanpy-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1dc2c58207fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+#Maintainer: Bjoern Franke <bjo+aur@schafweide.org>
+pkgname=phanpy-bin
+_pkgver=2024.10.15.e3df9ff
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="A minimalistic opinionated Mastodon web client"
+arch=('x86_64')
+url="https://github.com/cheeaun/phanpy/"
+license=('MIT')
+provides=('phanpy')
+conflicts=('phanpy')
+source=("https://github.com/cheeaun/phanpy/releases/download/${_pkgver}/phanpy-dist.tar.gz")
+sha256sums=('2153f1ea7214f2c200e4aa081eb1351082ff59b7d9a92a73252d5fcbdceee68c')
+
+package() {
+ cd ${srcdir}
+ install -d "${pkgdir}"/usr/share/webapps/phanpy/
+ cp -r * "${pkgdir}"/usr/share/webapps/phanpy/
+ echo "${pkgver}" > "${pkgdir}"/usr/share/webapps/phanpy/version
+
+}
+