summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Walenciak2024-02-09 16:09:48 +0100
committerMichał Walenciak2024-02-09 16:09:48 +0100
commitd5eb7bcceeb1a6e67b208f6775b08d10de5b7807 (patch)
tree2a1ae65562ce24a0b456a15d95a78868c463eadc
parentec81b6566edce2b0cbd011267bf795a2c46d5a3e (diff)
downloadaur-photobroom-git.tar.gz
Adopt to changes
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 10 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 589131998bed..40628ec6f61b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = photobroom-git
pkgdesc = Photos managing tool
- pkgver = v1.6.0.r461.g947e54877
+ pkgver = v1.6.0.r529.g8dfc50393
pkgrel = 1
url = https://github.com/Kicer86/photobroom
arch = i686
@@ -13,13 +13,12 @@ pkgbase = photobroom-git
makedepends = libwebp
makedepends = cs-libguarded
makedepends = boost
- makedepends = clang
- makedepends = llvm
depends = exiv2
depends = qt6-base
depends = qt6-multimedia
depends = qt6-declarative
depends = qt6-svg
+ depends = qt6-quick3d
depends = dlib
depends = opencv
depends = jsoncpp
@@ -27,11 +26,9 @@ pkgbase = photobroom-git
conflicts = photobroom
source = photobroom-git::git+https://github.com/Kicer86/photobroom.git#branch=master
source = cmake_modules::git+https://github.com/Kicer86/cmake_modules.git#commit=bf447aeb3bf57680f0c257f9d77ea7f5ef90b0ec
- source = qml-colorpicker::git+https://github.com/rshest/qml-colorpicker.git#commit=5967b3e38033794f54d66c57a03f9a356df0dc03
source = face_recognition_models::git+https://github.com/ageitgey/face_recognition_models.git#commit=e67de717267507d1e9246de95692eb8be736ab61
source = animated_webp::git+https://github.com/Kicer86/AnimatedWebP.git#commit=996e92a0c45b2ea20034c9e97ec75d2098faf2f8
- source = reflectpp::git+https://github.com/Kicer86/reflectpp.git#commit=5dc631cb129dd6a5dbdcab8836ba7e0772c2b02c
- md5sums = SKIP
+ source = reflect-cpp::git+https://github.com/getml/reflect-cpp.git#commit=0a524a9893fc1220fe38734dac311b032edd4b79
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 20bd69db98de..6bf65f9dc0db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Michał Walenciak <kicer86@gmail.com>
pkgname=photobroom-git
-pkgver=v1.6.0.r461.g947e54877
+pkgver=v1.6.0.r529.g8dfc50393
pkgrel=1
pkgdesc="Photos managing tool"
arch=('i686' 'x86_64')
url="https://github.com/Kicer86/photobroom"
license=('GPL3')
groups=()
-depends=('exiv2' 'qt6-base' 'qt6-multimedia' 'qt6-declarative' 'qt6-svg' 'dlib' 'opencv' 'jsoncpp')
-makedepends=('cmake' 'magic_enum' 'qt6-tools' 'imagemagick' 'libwebp' 'cs-libguarded' 'boost' 'clang' 'llvm')
+depends=('exiv2' 'qt6-base' 'qt6-multimedia' 'qt6-declarative' 'qt6-svg' 'qt6-quick3d' 'dlib' 'opencv' 'jsoncpp')
+makedepends=('cmake' 'magic_enum' 'qt6-tools' 'imagemagick' 'libwebp' 'cs-libguarded' 'boost')
optdepends=()
provides=('photobroom')
conflicts=('photobroom')
@@ -19,19 +19,16 @@ install=
changelog=
source=(photobroom-git::git+https://github.com/Kicer86/photobroom.git#branch=master
cmake_modules::git+https://github.com/Kicer86/cmake_modules.git#commit=bf447aeb3bf57680f0c257f9d77ea7f5ef90b0ec
- qml-colorpicker::git+https://github.com/rshest/qml-colorpicker.git#commit=5967b3e38033794f54d66c57a03f9a356df0dc03
face_recognition_models::git+https://github.com/ageitgey/face_recognition_models.git#commit=e67de717267507d1e9246de95692eb8be736ab61
animated_webp::git+https://github.com/Kicer86/AnimatedWebP.git#commit=996e92a0c45b2ea20034c9e97ec75d2098faf2f8
- reflectpp::git+https://github.com/Kicer86/reflectpp.git#commit=5dc631cb129dd6a5dbdcab8836ba7e0772c2b02c
+ reflect-cpp::git+https://github.com/getml/reflect-cpp.git#commit=0a524a9893fc1220fe38734dac311b032edd4b79
)
noextract=()
md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- 'SKIP'
-)
+ 'SKIP')
pkgver() {
cd "$pkgname"
@@ -41,15 +38,13 @@ pkgver() {
prepare()
{
rm -d $pkgname/cmake_modules
- rm -d $pkgname/src/gui/desktop/quick_items/external/qml-colorpicker
rm -d $pkgname/src/gui/desktop/utils/animated_webp
rm -d $pkgname/src/face_recognition/dlib_wrapper/face_recognition_models
- rm -d $pkgname/tools/reflect++
+ rm -d $pkgname/src/third_party/reflect-cpp
ln -s ../cmake_modules $pkgname/cmake_modules
- ln -s ../../../../../../qml-colorpicker $pkgname/src/gui/desktop/quick_items/external/qml-colorpicker
ln -s ../../../../../animated_webp $pkgname/src/gui/desktop/utils/animated_webp
ln -s ../../../../face_recognition_models $pkgname/src/face_recognition/dlib_wrapper/face_recognition_models
- ln -s ../../reflectpp $pkgname/tools/reflect++
+ ln -s ../../../reflect-cpp $pkgname/src/third_party/reflect-cpp
}
build()