summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThore Boedecker2016-01-12 22:01:26 +0100
committerThore Boedecker2016-01-12 22:01:26 +0100
commit9d5968f03b979f47cff8ddf81c13f06cf13fb881 (patch)
treeaa224bd264dd18c336939d7845f4a066541bcc07
downloadaur-9d5968f03b979f47cff8ddf81c13f06cf13fb881.tar.gz
Initial commit including a working PKGBUILD
Signed-off-by: Thore Boedecker <me@foxxx0.de>
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae6ed4b77150
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Jan 12 21:00:13 UTC 2016
+pkgbase = php56-apcu
+ pkgdesc = A userland caching module for php56
+ pkgver = 4.0.10
+ pkgrel = 1
+ url = https://pecl.php.net/package/APCu
+ arch = i686
+ arch = x86_64
+ license = PHP
+ depends = php56>=5.6.17-2
+ provides = php-apcu=4.0.10-1
+ backup = opt/php56/etc/php/conf.d/apcu.ini
+ source = https://pecl.php.net/get/apcu-4.0.10.tgz
+ md5sums = e52d930a050066025095e2a448fd3cab
+
+pkgname = php56-apcu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4cd011154d61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Thore Bödecker <me at foxxx0 dot de>
+
+pkgname=php56-apcu
+_pkgbase="${pkgname#php56-}"
+_phpbase="${pkgname/-apcu}"
+_buildprefix="/opt/${_phpbase}"
+pkgver=4.0.10
+pkgrel=1
+pkgdesc="A userland caching module for php56"
+arch=('i686' 'x86_64')
+url="https://pecl.php.net/package/APCu"
+license=('PHP')
+depends=('php56>=5.6.17-2')
+provides=("php-${_pkgbase}=${pkgver}-${pkgrel}")
+backup=("${_buildprefix#/}/etc/php/conf.d/apcu.ini")
+source=("https://pecl.php.net/get/${_pkgbase}-${pkgver}.tgz")
+md5sums=('e52d930a050066025095e2a448fd3cab')
+
+build() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ ${_buildprefix}/bin/phpize
+ ./configure --config-cache \
+ --prefix=${_buildprefix} \
+ --sbindir=${_buildprefix}/bin \
+ --sysconfdir=${_buildprefix}/etc/php \
+ --with-php-config=${_buildprefix}/bin/php-config \
+ --localstatedir=/var \
+ --mandir=${_buildprefix}/share/man
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ make INSTALL_ROOT="$pkgdir" install
+ echo ';extension=apcu.so' > apcu.ini
+ install -D -m644 apcu.ini "${pkgdir}/${_buildprefix#/}/etc/php/conf.d/apcu.ini"
+ install -D -m644 apc.php "${pkgdir}/usr/share/php56-apcu/apc.php"
+ install -D -m644 INSTALL "${pkgdir}/usr/share/doc/php56-apcu/install.txt"
+}