aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Bayer2021-01-29 10:12:10 +0100
committerChristoph Bayer2021-01-29 10:12:10 +0100
commit8f1a60f67bfbb58adf980bd52ca541de1134701d (patch)
tree4502763ec3d4c17200718249d7748057f0fc6fe5
downloadaur-php7-gnupg.tar.gz
Initial version 1.4.0
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--Dockerfile9
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD31
-rw-r--r--README.md32
-rw-r--r--docker-compose.yml4
-rw-r--r--php-gnupg.install13
8 files changed, 132 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2196c817ce8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = php7-gnupg
+ pkgdesc = PHP extension for gnupg/gpgme.
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://pecl.php.net/package/gnupg
+ install = php-gnupg.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = php7
+ depends = gpgme
+ backup = etc/php7/conf.d/gnupg.ini
+ source = https://pecl.php.net/get/gnupg-1.4.0.tgz
+ md5sums = 2354cb56168d8ea0f643e548e139d013
+
+pkgname = php7-gnupg
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0419eed3b59a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/gnupg-*.tgz
+/php-gnupg-*.pkg.tar.xz
+/php-gnupg-*.src.tar.gz
+/pkg/
+/src/
diff --git a/Dockerfile b/Dockerfile
new file mode 100644
index 000000000000..7961ad2619f8
--- /dev/null
+++ b/Dockerfile
@@ -0,0 +1,9 @@
+FROM nubs/arch-build
+
+MAINTAINER Spencer Rinehart <anubis@overthemonkey.com>
+
+USER root
+
+RUN pacman --sync --refresh --noconfirm --noprogressbar --quiet && pacman --sync --noconfirm --noprogressbar --quiet php gpgme
+
+USER build
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..4efa9e99f6ce
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2014-2016 Spencer Rinehart
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b55d6a518949
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Christoph Bayer <chrbayer@criby.de>
+
+pkgname=php7-gnupg
+_extname=gnupg
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="PHP extension for gnupg/gpgme."
+arch=('i686' 'x86_64')
+url="https://pecl.php.net/package/${_extname}"
+license=('BSD')
+depends=('php7' 'gpgme')
+backup=("etc/php7/conf.d/${_extname}.ini")
+install="php-${_extname}.install"
+source=("https://pecl.php.net/get/${_extname}-${pkgver}.tgz")
+md5sums=('2354cb56168d8ea0f643e548e139d013')
+
+build() {
+ cd "${_extname}-${pkgver}"
+
+ phpize7
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${_extname}-${pkgver}"
+
+ make INSTALL_ROOT="${pkgdir}" install
+ echo "extension=${_extname}.so" > "${_extname}.ini"
+ install -D -m644 "${_extname}.ini" "${pkgdir}/etc/php7/conf.d/${_extname}.ini"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..cd96f79ff470
--- /dev/null
+++ b/README.md
@@ -0,0 +1,32 @@
+# php-gnupg-aur
+An [AUR] package build for PHP's [gnupg] extension.
+
+## Building
+You can of course build this package using [makepkg], but the recommended way
+of building this package is using [Docker]. This can be done like so:
+
+```bash
+docker build --tag php-gnupg-aur .
+docker run --rm --volume "$(pwd):/package" php-gnupg-aur
+```
+
+Alternatively, using [Docker Compose]:
+
+```bash
+docker-compose run build
+```
+
+This will start create a docker image tagged as php-gnupg-aur and build the
+package inside the container. As a result you should get the built package in
+your current directory.
+
+## License
+php-gnupg-aur is licensed under the MIT license. See [LICENSE] for the full
+license text.
+
+[AUR]: https://aur.archlinux.org/
+[gnupg]: https://pecl.php.net/package/gnupg
+[makepkg]: https://wiki.archlinux.org/index.php/Makepkg
+[Docker]: https://www.docker.com/
+[Docker Compose]: https://docs.docker.com/compose/
+[LICENSE]: https://github.com/nubs/php-gnupg-aur/blob/master/LICENSE
diff --git a/docker-compose.yml b/docker-compose.yml
new file mode 100644
index 000000000000..b11c60fa7962
--- /dev/null
+++ b/docker-compose.yml
@@ -0,0 +1,4 @@
+build:
+ build: .
+ volumes:
+ - ".:/package"
diff --git a/php-gnupg.install b/php-gnupg.install
new file mode 100644
index 000000000000..3a6abe16c103
--- /dev/null
+++ b/php-gnupg.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo '
+ ==> PHP extension
+
+ A config file was stored under /etc/php7/conf.d/ with the extension enabled.
+ '
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et: