summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Viallon2019-11-23 02:09:33 +0100
committerAntoine Viallon2019-11-23 02:09:33 +0100
commita889561c6b15ae562e6b160893b12c07fdd97ecf (patch)
tree3ac27c532dfee65392995db75c4349e4a3c48613
downloadaur-phppgadmin-relhasoids.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d4f197e46ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = phppgadmin-relhasoids
+ pkgdesc = The premier web-based administration tool for postgresql
+ pkgver = 7.12.1
+ pkgrel = 1
+ url = https://github.com/xzilla/phppgadmin/tree/relhasoids
+ arch = i686
+ arch = x86_64
+ license = GPLv2
+ makedepends = git
+ provides = phppgadmin
+ conflicts = phppgadmin
+ source = git+https://github.com/xzilla/phppgadmin#branch=relhasoids
+ md5sums = SKIP
+
+pkgname = phppgadmin-relhasoids
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f8a179bd127
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Antoine Viallon <antoine.viallon@gmail.com>
+
+pkgname=phppgadmin-relhasoids
+_pkgname=${pkgname%-relhasoids}
+pkgver=7.12.1
+pkgrel=1
+pkgdesc="The premier web-based administration tool for postgresql"
+arch=('i686' 'x86_64')
+url="https://github.com/xzilla/phppgadmin/tree/relhasoids"
+license=('GPLv2')
+#depends=('')
+makedepends=('git')
+conflicts=('phppgadmin')
+provides=('phppgadmin')
+source=(git+https://github.com/xzilla/phppgadmin#branch=relhasoids)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ cat HISTORY | grep "Version" | head -n 1 | cut -d " " -f 2
+ #git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ #printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package(){
+# shopt -s glob
+ mkdir -p $pkgdir/usr/share/webapps/phppgadmin/
+ cp -Rv $srcdir/$_pkgname/* $pkgdir/usr/share/webapps/phppgadmin/
+ chown -R http:http $pkgdir/usr/share/webapps/phppgadmin/
+ chmod -R 644 $pkgdir/usr/share/webapps/phppgadmin/
+}