summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2015-06-13 11:57:03 +0200
committerChristian Krause2015-06-13 11:57:03 +0200
commitd8fa8a4d4ceeda5f265a7bdbfff4a0120ab7dfa5 (patch)
tree075d8e6f1ccf69f345f99751881a88e7a724c5e1
downloadaur-phyml-git.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD44
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5055d0fcd11b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = phyml-git
+ pkgdesc = Phylogenetic estimation using (Maximum) Likelihood
+ pkgver = r121.ab59039
+ pkgrel = 1
+ url = https://github.com/stephaneguindon/phyml/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = glibc
+ provides = phyml
+ conflicts = phyml
+ source = phyml-git::git+https://github.com/stephaneguindon/phyml
+ md5sums = SKIP
+
+pkgname = phyml-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af2c38d855fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
+
+pkgname=phyml-git
+pkgver=r121.ab59039
+pkgrel=1
+pkgdesc="Phylogenetic estimation using (Maximum) Likelihood"
+arch=('i686' 'x86_64')
+url="https://github.com/stephaneguindon/phyml/"
+license=('GPL2')
+depends=('glibc')
+conflicts=('phyml')
+provides=('phyml')
+
+source=("$pkgname::git+https://github.com/stephaneguindon/phyml")
+
+md5sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/$pkgname
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $srcdir/$pkgname
+
+ autoreconf -fi
+}
+
+build() {
+ cd $srcdir/$pkgname
+
+ ./configure \
+ --prefix=/usr \
+ --disable-static
+
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname
+
+ make DESTDIR=$pkgdir install
+}