summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2017-07-04 16:57:11 -0400
committergraysky2017-07-04 16:57:11 -0400
commit67ede212cb191bbc72c0d03041f5cc235b20b6b3 (patch)
tree1975b77e4994e10a408b0ef5b797dc5a67dd7214
parent7d314eaa95a92fb51a1d7728cd8089261cbc8416 (diff)
downloadaur-67ede212cb191bbc72c0d03041f5cc235b20b6b3.tar.gz
cleanup and standardize some files in PKGBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD33
-rw-r--r--blacklist.txt0
-rw-r--r--whitelist.txt0
4 files changed, 24 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7012b6d872fd..ce8027080efa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Tue Jul 4 20:56:54 UTC 2017
pkgbase = pi-hole-server
pkgdesc = The Pi-hole is an advertising-aware DNS/Web server. Arch adaptation for lan wide DNS server.
pkgver = 3.1
- pkgrel = 8
+ pkgrel = 9
url = https://github.com/pi-hole/pi-hole
install = pi-hole-server.install
arch = any
@@ -32,8 +34,6 @@ pkgbase = pi-hole-server
source = pi-hole-gravity.timer
source = pi-hole-logtruncate.service
source = pi-hole-logtruncate.timer
- source = whitelist.txt
- source = blacklist.txt
source = mimic_setupVars.conf.sh
source = version.patch
md5sums = e24ce6a12ee97cd7de2c5ab13af99511
@@ -49,8 +49,6 @@ pkgbase = pi-hole-server
md5sums = d42a864f88299998f8233c0bc0dd093d
md5sums = 94d5aa0e8aa3d4170bcea71078a9da25
md5sums = 291d3c95e445fe65caf40c3605efd186
- md5sums = d41d8cd98f00b204e9800998ecf8427e
- md5sums = d41d8cd98f00b204e9800998ecf8427e
md5sums = 966a61aee3948cdfd92f1eb1a8180f1d
md5sums = 93fe5e50cf3fcb08b24cf29b0cace85b
diff --git a/PKGBUILD b/PKGBUILD
index 1b9facc8582c..305ed3db1413 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=pi-hole-server
_pkgname=pi-hole
pkgver=3.1
-pkgrel=8
+pkgrel=9
_wwwpkgname=AdminLTE
_wwwpkgver=3.1
pkgdesc='The Pi-hole is an advertising-aware DNS/Web server. Arch adaptation for lan wide DNS server.'
@@ -35,8 +35,6 @@ source=(pihole-$pkgver.tar.gz::https://github.com/$_pkgname/$_pkgname/archive/v$
$_pkgname-gravity.timer
$_pkgname-logtruncate.service
$_pkgname-logtruncate.timer
- whitelist.txt
- blacklist.txt
mimic_setupVars.conf.sh
version.patch)
@@ -53,8 +51,6 @@ md5sums=('e24ce6a12ee97cd7de2c5ab13af99511'
'd42a864f88299998f8233c0bc0dd093d'
'94d5aa0e8aa3d4170bcea71078a9da25'
'291d3c95e445fe65caf40c3605efd186'
- 'd41d8cd98f00b204e9800998ecf8427e'
- 'd41d8cd98f00b204e9800998ecf8427e'
'966a61aee3948cdfd92f1eb1a8180f1d'
'93fe5e50cf3fcb08b24cf29b0cace85b')
@@ -294,24 +290,37 @@ package() {
ln -s $_pkgname-logtruncate.timer "$pkgdir/usr/lib/systemd/system/multi-user.target.wants/$_pkgname-logtruncate.timer"
install -dm755 "$pkgdir"/etc/pihole
- install -dm755 "$pkgdir"/etc/pihole/configs
+ install -dm755 "$pkgdir"/usr/share/pihole/configs
+ install -dm755 "$pkgdir"/usr/share/pihole/doc
install -Dm644 $_pkgname-$pkgver/adlists.default "$pkgdir"/etc/pihole/adlists.default
install -Dm644 $_pkgname-$pkgver/advanced/logrotate "$pkgdir"/etc/pihole/logrotate
- install -Dm644 whitelist.txt "$pkgdir"/etc/pihole/whitelist.txt
- install -Dm644 blacklist.txt "$pkgdir"/etc/pihole/blacklist.txt
+ install -Dm644 /dev/null "$pkgdir"/etc/pihole/whitelist.txt
+ install -Dm644 /dev/null "$pkgdir"/etc/pihole/blacklist.txt
- install -Dm644 configuration "$pkgdir"/usr/share/doc/pihole/configuration
+ install -Dm644 configuration "$pkgdir"/usr/share//pihole/doc/configuration
- install -Dm644 dnsmasq.main "$pkgdir"/etc/pihole/configs/dnsmasq.main
+ install -Dm644 dnsmasq.main "$pkgdir"/usr/share/pihole/configs/dnsmasq.main
install -Dm644 dnsmasq.include "$pkgdir"/etc/dnsmasq.d/01-pihole.conf
install -Dm644 dnsmasq.local "$pkgdir"/etc/dnsmasq.d/02-pihole.conf
- install -Dm644 lighttpd.conf "$pkgdir"/etc/pihole/configs/lighttpd.conf
- install -Dm644 nginx.pi-hole.conf "$pkgdir"/etc/pihole/configs/nginx.pi-hole.conf
+ install -Dm644 lighttpd.conf "$pkgdir"/usr/share/pihole/configs/lighttpd.example.conf
+ install -Dm644 nginx.pi-hole.conf "$pkgdir"/usr/share/pihole/configs/nginx.example.conf
install -dm755 "$pkgdir"/srv/http/pihole/admin
install -Dm644 $_pkgname-$pkgver/advanced/index.php "$pkgdir"/srv/http/pihole/pihole/index.php
install -Dm644 $_pkgname-$pkgver/advanced/index.js "$pkgdir"/srv/http/pihole/pihole/index.js
install -Dm644 $_pkgname-$pkgver/advanced/blockingpage.css "$pkgdir"/srv/http/pihole/pihole/blockingpage.css
cp -dpr --no-preserve=ownership $_wwwpkgname-$_wwwpkgver/* "$pkgdir"/srv/http/pihole/admin/
+
+ install -dm755 "$pkgdir"/usr/share/licenses/pihole
+ install -Dm644 ${pkgname%-*}-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/pihole/Pi-hole
+ install -Dm644 AdminLTE-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/pihole/AdminLTE
+ install -Dm644 AdminLTE-$pkgver/style/vendor/SourceSansPro/OFL.txt \
+ "$pkgdir"/usr/share/licenses/pihole/SourceSansPro
+
+ rm "$pkgdir"/srv/http/pihole/admin/*.md
+ rm "$pkgdir"/srv/http/pihole/admin/LICENSE
+ rm "$pkgdir"/srv/http/pihole/admin/style/vendor/LICENSE
+ rm "$pkgdir"/srv/http/pihole/admin/scripts/vendor/LICENSE
+ rm "$pkgdir"/srv/http/pihole/admin/style/vendor/SourceSansPro/OFL.txt
}
diff --git a/blacklist.txt b/blacklist.txt
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/blacklist.txt
+++ /dev/null
diff --git a/whitelist.txt b/whitelist.txt
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/whitelist.txt
+++ /dev/null