summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormax.bra2017-12-11 22:52:24 +0100
committermax.bra2017-12-11 22:52:24 +0100
commitf5a9e715ebd79c44f3003f128af61c0352088088 (patch)
tree4cddd6131e82a6f6f6ce504ac8fde350e9824942
parent3e4b5cefb79f5555f05f2f6b10a18277c92b3f70 (diff)
downloadaur-f5a9e715ebd79c44f3003f128af61c0352088088.tar.gz
recursive error
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--issue_1598.patch25
-rw-r--r--pi-hole-server.install4
4 files changed, 29 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aea19756e7b9..4864cbd88dc4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pi-hole-server
pkgdesc = The Pi-hole is an advertising-aware DNS/Web server. Arch adaptation for lan wide DNS server.
pkgver = 3.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/pi-hole/pi-hole
install = pi-hole-server.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 42849a685428..477cf1de24e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=pi-hole-server
_pkgname=pi-hole
pkgver=3.2
-pkgrel=2
+pkgrel=3
_wwwpkgname=AdminLTE
_wwwpkgver=3.2
pkgdesc='The Pi-hole is an advertising-aware DNS/Web server. Arch adaptation for lan wide DNS server.'
diff --git a/issue_1598.patch b/issue_1598.patch
new file mode 100644
index 000000000000..aefaaf06f7d4
--- /dev/null
+++ b/issue_1598.patch
@@ -0,0 +1,25 @@
+From 9934f505a5c717d39167f705a818b25e8cdfda5a Mon Sep 17 00:00:00 2001
+From: Molikuner <molikuner@gmail.com>
+Date: Thu, 13 Jul 2017 23:18:40 +0200
+Subject: [PATCH] Fix URL extension parsing
+
+when there is a querystring Pi-hole sometimes parsed a wrong extension
+---
+ advanced/index.php | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/advanced/index.php b/advanced/index.php
+index 1dd5acc77..2facd144b 100644
+--- a/advanced/index.php
++++ b/advanced/index.php
+@@ -21,8 +21,9 @@ function validIP($address){
+ }
+
+ // Retrieve server URI extension (EG: jpg, exe, php)
++// strtok($uri, '\?') splits the querystring from the path (if there is a querystring)
+ ini_set('pcre.recursion_limit',100);
+-$uriExt = pathinfo($uri, PATHINFO_EXTENSION);
++$uriExt = pathinfo(strtok($uri,'\?'), PATHINFO_EXTENSION);
+
+ // Define which URL extensions get rendered as "Website Blocked"
+ $webExt = array('asp', 'htm', 'html', 'php', 'rss', 'xml'); \ No newline at end of file
diff --git a/pi-hole-server.install b/pi-hole-server.install
index 439188c2752c..4114ed3eca30 100644
--- a/pi-hole-server.install
+++ b/pi-hole-server.install
@@ -6,7 +6,7 @@ post_install() {
echo -e "\e[1;33m==>\e[0m Read setup instructions at \e[1;36mhttps://wiki.archlinux.org/index.php/Pi-hole\e[0m"
echo -e "\e[1;33m==>\e[0m Generating initial block list, please wait...\e[0m"
chown -R http:http /srv/http/pihole
- chown -R pihole:pihole /etc/pihole
+ chown pihole:pihole /etc/pihole
/opt/pihole/mimic_setupVars.conf.sh
# update lists on first run
@@ -23,7 +23,7 @@ post_upgrade() {
[ -e /etc/pihole/.useIPv6 ] && rm /etc/pihole/.useIPv6
# update owner of existing dir
- chown -R pihole:pihole /etc/pihole
+ chown pihole:pihole /etc/pihole
warning