summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnish Bhatt2016-08-02 01:09:29 -0700
committerAnish Bhatt2016-08-02 01:09:29 -0700
commit609e7b83310ac615e85ad7a4d5c915d1d92c1b12 (patch)
tree5602e2b75a5c77b219fc9e04918afcb791c43ddd
parent4f264965a5ea986dfe1599f2fbecc21ff500beff (diff)
downloadaur-609e7b83310ac615e85ad7a4d5c915d1d92c1b12.tar.gz
Add piaware user and default config file
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
-rw-r--r--piaware-git.install5
-rw-r--r--piaware.conf2
4 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58ca5a8bae72..3e67d3277504 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = piaware-git
pkgdesc = Client-side package and programs for forwarding ADS-B data to FlightAware
pkgver = 3.0.2.r0.g1fd4d7f
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/flightaware/piaware
install = piaware-git.install
arch = i686
@@ -23,8 +23,11 @@ pkgbase = piaware-git
depends = python
depends = tcllauncher
optdepends = mlat-client: M-LAT support
+ backup = etc/piaware.conf
source = piaware::git+git://github.com/flightaware/piaware
+ source = piaware.conf
md5sums = SKIP
+ md5sums = 9fcbaadb1d08e755c3c1e7e577f0ac32
pkgname = piaware-git
diff --git a/PKGBUILD b/PKGBUILD
index 4b2cc028159e..63b8524b98ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=piaware-git
_gitname=piaware
pkgver=3.0.2.r0.g1fd4d7f
-pkgrel=1
+pkgrel=2
pkgdesc="Client-side package and programs for forwarding ADS-B data to FlightAware"
@@ -16,9 +16,12 @@ depends=('dump1090-fa-git' 'tcl' 'tcllib' 'tclx' 'tk' 'tls' 'python' 'tcllaunche
makedepends=('git' 'autoconf' 'tcl' 'python' 'tcllauncher')
optdepends=('mlat-client: M-LAT support')
-source=('piaware::git+git://github.com/flightaware/piaware')
-md5sums=('SKIP')
+source=('piaware::git+git://github.com/flightaware/piaware'
+ 'piaware.conf')
+md5sums=('SKIP'
+ '9fcbaadb1d08e755c3c1e7e577f0ac32')
install=piaware-git.install
+backup=('etc/piaware.conf')
_gitname=piaware
@@ -34,6 +37,9 @@ package() {
make install DESTDIR=${pkgdir} SYSTEMD=/usr/lib/systemd/system
rm ${pkgdir}/usr/bin/tcllauncher
+ install -dm750 ${pkgdir}/etc/sudoers.d/
+ install -Dm644 etc/piaware.sudoers ${pkgdir}/etc/sudoers.d/01piaware
+ install -Dm644 ${srcdir}/piaware.conf ${pkgdir}/etc/piaware.conf
chmod -x "${pkgdir}/usr/lib/systemd/system/piaware.service"
install -Dm644 LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
diff --git a/piaware-git.install b/piaware-git.install
index 5d16f782b815..060a67904c00 100644
--- a/piaware-git.install
+++ b/piaware-git.install
@@ -1,4 +1,5 @@
post_install() {
+ useradd -M piaware
systemctl enable piaware
}
@@ -6,3 +7,7 @@ pre_remove() {
systemctl stop piaware
systemctl disable piaware
}
+
+post_upgrade() {
+ post_install
+}
diff --git a/piaware.conf b/piaware.conf
new file mode 100644
index 000000000000..89120cdc299a
--- /dev/null
+++ b/piaware.conf
@@ -0,0 +1,2 @@
+flightaware-user foo
+flightaware-password bar