summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Groocock2020-03-07 22:42:06 +0000
committerJoe Groocock2020-03-07 22:42:06 +0000
commitf976e7c3a224d7dcab8f5d1af4eb0f8074817853 (patch)
tree9d4126ad5276539783d1f06143e5ecab133d96e0
parentf78626d611d8f156241ad81f20c246489d185cd5 (diff)
downloadaur-f976e7c3a224d7dcab8f5d1af4eb0f8074817853.tar.gz
Rebase latest yshui/picom changes
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 38bccd8e7120..d37e0ac71668 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=picom-tryone-git
_gitname=compton
-pkgver=1298_0.1_beta2.949.gf92eb6b_2019.12.21
+pkgver=1325_Next.44.g7e31e28_2020.03.07
pkgrel=1
pkgdesc="tryone144's picom fork with dual_kawase blur, an X compositor (fork of compton)"
arch=(i686 x86_64)
@@ -33,6 +33,13 @@ pkgver() {
printf "%s_%s_%s\n" "${_commits}" "${_tag}" "${_date}" | sed 's/-/./g'
}
+prepare() {
+ cd "${srcdir}/${_gitname}"
+ git remote add yshui https://github.com/yshui/picom.git
+ git fetch yshui
+ git rebase yshui/next
+}
+
build() {
cd "${srcdir}/${_gitname}"
meson --buildtype=debug . build --prefix=/usr -Dwith_docs=true