summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-07 17:36:55 +0100
committerBartłomiej Piotrowski2018-01-07 17:36:55 +0100
commit6d588e70df460ad6e5d0cc9e95cecac425e42498 (patch)
treec63b2e5a681b45031e1daa64d4d2f9511e6ea340
downloadaur-pidgin-encryption.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
-rw-r--r--fix_header_escaping.patch64
-rw-r--r--log_crash.patch11
4 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bda9a6ac5195
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pidgin-encryption
+ pkgdesc = A Pidgin plugin providing transparent RSA encryption using NSS
+ pkgver = 3.1
+ pkgrel = 3
+ url = http://pidgin-encrypt.sourceforge.net/
+ arch = x86_64
+ license = GPL
+ depends = pidgin
+ depends = nss
+ source = http://downloads.sourceforge.net/pidgin-encrypt/pidgin-encryption-3.1.tar.gz
+ md5sums = d839eec602c21f913b32b742dc512f4b
+
+pkgname = pidgin-encryption
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cff221be73dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Dan McGee <dan@archlinux.org>
+# Contributor: Dale Blount <dale@archlinux.org>
+
+pkgname=pidgin-encryption
+pkgver=3.1
+pkgrel=3
+pkgdesc="A Pidgin plugin providing transparent RSA encryption using NSS"
+arch=('x86_64')
+license=('GPL')
+url="http://pidgin-encrypt.sourceforge.net/"
+depends=('pidgin' 'nss')
+source=(http://downloads.sourceforge.net/pidgin-encrypt/$pkgname-$pkgver.tar.gz)
+md5sums=('d839eec602c21f913b32b742dc512f4b')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/fix_header_escaping.patch b/fix_header_escaping.patch
new file mode 100644
index 000000000000..84df67b1913e
--- /dev/null
+++ b/fix_header_escaping.patch
@@ -0,0 +1,64 @@
+--- pidgin-encryption-3.0.orig/encrypt.c 2007-05-06 23:37:55.000000000 -0400
++++ pidgin-encryption-3.0.new/encrypt.c 2009-11-22 22:28:34.052010351 -0500
+@@ -1114,21 +1114,21 @@ static void PE_headers_init() {
+ notify_table = g_hash_table_new_full(g_str_hash, g_str_equal, g_free, g_free);
+
+ g_hash_table_insert(header_table, g_strdup("prpl-toc"),
+- g_strdup("*** Encrypted with the Gaim-Encryption plugin <A HREF=\""));
++ g_strdup("--- Encrypted with the Gaim-Encryption plugin <A HREF=\""));
+ g_hash_table_insert(footer_table, g_strdup("prpl-toc"),
+ g_strdup("\"></A>"));
+ g_hash_table_insert(notify_table, g_strdup("prpl-toc"),
+ g_strdup("<A HREF=\"Gaim-Encryption Capable\"></A>"));
+
+ g_hash_table_insert(header_table, g_strdup("prpl-oscar"),
+- g_strdup("*** Encrypted with the Gaim-Encryption plugin <A HREF=\""));
++ g_strdup("--- Encrypted with the Gaim-Encryption plugin <A HREF=\""));
+ g_hash_table_insert(footer_table, g_strdup("prpl-oscar"),
+ g_strdup("\"></A>"));
+ g_hash_table_insert(notify_table, g_strdup("prpl-oscar"),
+ g_strdup("<A HREF=\"Gaim-Encryption Capable\"></A>"));
+
+ g_hash_table_insert(header_table, g_strdup("prpl-aim"),
+- g_strdup("*** Encrypted with the Gaim-Encryption plugin <A HREF=\""));
++ g_strdup("--- Encrypted with the Gaim-Encryption plugin <A HREF=\""));
+ g_hash_table_insert(footer_table, g_strdup("prpl-aim"),
+ g_strdup("\"></A>"));
+ g_hash_table_insert(notify_table, g_strdup("prpl-aim"),
+@@ -1136,7 +1136,7 @@ static void PE_headers_init() {
+
+ /* If jabber stops stripping HTML, we can go back to these headers */
+ /* g_hash_table_insert(header_table, g_strdup("prpl-jabber"), */
+-/* g_strdup("*** Encrypted with the Gaim-Encryption plugin <A HREF='")); */
++/* g_strdup("--- Encrypted with the Gaim-Encryption plugin <A HREF='")); */
+ /* g_hash_table_insert(footer_table, g_strdup("prpl-jabber"), */
+ /* g_strdup("'></A>")); */
+ /* g_hash_table_insert(notify_table, g_strdup("prpl-jabber"), */
+@@ -1144,22 +1144,22 @@ static void PE_headers_init() {
+
+
+ g_hash_table_insert(header_table, g_strdup("prpl-jabber"),
+- g_strdup("*** Encrypted with the Gaim-Encryption plugin "));
++ g_strdup("--- Encrypted with the Gaim-Encryption plugin "));
+ g_hash_table_insert(footer_table, g_strdup("prpl-jabber"),
+ g_strdup(" "));
+ g_hash_table_insert(notify_table, g_strdup("prpl-jabber"),
+ g_strdup("<A HREF='Gaim-Encryption Capable'> </A>"));
+
+- header_default = g_strdup("*** Encrypted :");
++ header_default = g_strdup("--- Encrypted :");
+ }
+
+-/* #define CRYPT_HEADER "*** Encrypted with the Gaim-Encryption plugin <A HREF=\"" */
++/* #define CRYPT_HEADER "--- Encrypted with the Gaim-Encryption plugin <A HREF=\"" */
+ /* #define CRYPT_FOOTER "\"></A>" */
+ /* #define CRYPT_NOTIFY_HEADER "<A HREF=\"Gaim-Encryption Capable\"></A>" */
+
+ // Jabber seems to turn our double quotes into single quotes at times, so define
+ // the same headers, only with single quotes. Lengths MUST be the same as above
+-/* #define CRYPT_HEADER_MANGLED "*** Encrypted with the Gaim-Encryption plugin <A HREF='" */
++/* #define CRYPT_HEADER_MANGLED "--- Encrypted with the Gaim-Encryption plugin <A HREF='" */
+ /* #define CRYPT_NOTIFY_HEADER_MANGLED "<A HREF='Gaim-Encryption Capable'></A>" */
+
+
+
diff --git a/log_crash.patch b/log_crash.patch
new file mode 100644
index 000000000000..a184161445b0
--- /dev/null
+++ b/log_crash.patch
@@ -0,0 +1,11 @@
+--- pidgin-encryption-3.0.orig/state_ui.c 2007-05-07 02:15:27.000000000 +0200
++++ pidgin-encryption-3.0.new/state_ui.c 2009-04-26 17:08:02.000000000 +0200
+@@ -268,6 +268,8 @@
+ static GtkIMHtmlSmiley * create_smiley_if_absent(GtkIMHtml *imhtml) {
+ GtkIMHtmlSmiley * smiley;
+ const char* category = gtk_imhtml_get_protocol_name(imhtml);
++
++ if (!category) return NULL;
+
+ /* make sure that the category we're about to use to add (based on the protocol name) */
+ /* already exists. If it doesn't, just use the default category so it isn't created. */