summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordetiam2023-07-12 21:54:16 +0800
committerdetiam2023-07-12 21:54:16 +0800
commit2ce2aeb2fb01869175d9e395d0618fcebd9c10f6 (patch)
treeb7890e6a39fd804f1a7baa8257661bc749c3c6ea
parentc1addbc1c62153d2fe5507d48813f2a2f8fe5bcc (diff)
downloadaur-2ce2aeb2fb01869175d9e395d0618fcebd9c10f6.tar.gz
fix: `ModuleNotFoundError: No module named 'tr'`
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9719197280f1..912035c73ef1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# shellcheck disable=SC1090
# shellcheck disable=SC2206
pkgname=pince-git
-pkgver=r1300.7111db9
+pkgver=r1304.e31ea7c
pkgrel=1
pkgdesc="A Linux reverse engineering tool inspired by Cheat Engine."
arch=('any')
@@ -35,25 +35,23 @@ EOF
}
build() {
- pushd "$pkgname"
+ cd "$pkgname"
# Source libscanmem installation functions
. <(sed -n '/^compile_scanmem() /,/^}/p' install_pince.sh)
. <(sed -n '/^install_scanmem() /,/^}/p' install_pince.sh)
. <(sed -n '/^exit_on_error() /,/^}/p' install_pince.sh)
# Run functions
install_scanmem || exit_on_error
- popd
}
package() {
- pushd "$pkgname"
+ cd "$pkgname"
# Source PKG_NAMES* vars
. <(sed -n '/^PKG_NAMES/p' install_pince.sh)
# Set new depends
depends+=($PKG_NAMES_ARCH)
for pipkg in $PKG_NAMES_PIP; do
## why archlinux python package isn't just match "python-$pipkg" format?
- ## and one of these depends in aur are outdated now 2023/05/08
if [ "$pipkg" == "distorm3" ]; then
depends+=("python-distorm")
elif [ "$pipkg" == "pygobject" ]; then
@@ -70,6 +68,5 @@ package() {
install -d "$pkgdir/$_installpath"
install PINCE.sh PINCE.py \
COPYING COPYING.CC-BY AUTHORS THANKS "$pkgdir/$_installpath"
- cp -r GUI libpince media "$pkgdir/$_installpath"
- popd
+ cp -r GUI libpince media tr i18n "$pkgdir/$_installpath"
}