summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordetiam2024-03-16 19:29:07 +0800
committerdetiam2024-03-16 19:29:07 +0800
commit6500c141812ad3a1ac2e7a1e4dd64be6977efd3b (patch)
tree06b539378b5ec92543e100016d82edffd119c733
parent7faf35088b9596c11896caf330008426b9c6dda3 (diff)
downloadaur-6500c141812ad3a1ac2e7a1e4dd64be6977efd3b.tar.gz
update desktop icon
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore3
-rw-r--r--PINCE.desktop4
-rw-r--r--PKGBUILD27
-rw-r--r--note.install18
5 files changed, 47 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46f564c4b66e..c7cb89c796b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = pince-git
pkgdesc = A Linux reverse engineering tool inspired by Cheat Engine.
- pkgver = r1360.161758a
+ pkgver = r1472.a548c73
pkgrel = 1
url = https://github.com/korcankaraokcu/PINCE
+ install = note.install
arch = any
license = GPL3
makedepends = git
@@ -14,8 +15,8 @@ pkgbase = pince-git
optdepends = qt6-wayland: wayland support
source = pince-git::git+https://github.com/korcankaraokcu/PINCE.git
source = PINCE.desktop
- sha256sums = SKIP
- sha256sums = 33f145e61784d9f50b391e880d14a9d31a13d7b86cef0c8620f8f57fec0978bd
+ sha1sums = SKIP
+ sha1sums = 719d18d69abc299f739cc04041967e9d05a34104
pkgname = pince-git
depends = base-devel
diff --git a/.gitignore b/.gitignore
index 71ff8a0c92f1..4cc2389ce0f4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,5 @@
!.SRCINFO
!PKGBUILD
!.gitignore
-!PINCE.* \ No newline at end of file
+!PINCE.*
+!*.install
diff --git a/PINCE.desktop b/PINCE.desktop
index 949efe5831b1..5aab12885121 100644
--- a/PINCE.desktop
+++ b/PINCE.desktop
@@ -4,9 +4,9 @@ Comment=Reverse engineering tool for linux games
Comment[zh_CN]=用于 Linux 游戏的逆向工程工具
GenericName=PINCE
Exec=pince %U
-#Icon=PINCE
+Icon=PINCE
Type=Application
Terminal=true
StartupNotify=false
Categories=Qt;Utility;Development;
-MimeType=x-scheme-handler/PINCE; \ No newline at end of file
+MimeType=x-scheme-handler/PINCE;
diff --git a/PKGBUILD b/PKGBUILD
index 2d8e9724cdd1..f422e26f341c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# shellcheck disable=SC1090,SC2207
pkgname=pince-git
-pkgver=r1382.a0f99b5
+pkgver=r1472.a548c73
pkgrel=1
pkgdesc="A Linux reverse engineering tool inspired by Cheat Engine."
arch=('any')
@@ -16,7 +16,8 @@ optdepends=(
'qt6-wayland: wayland support'
)
source=("$pkgname::git+$url.git" 'PINCE.desktop')
-sha256sums=('SKIP' '33f145e61784d9f50b391e880d14a9d31a13d7b86cef0c8620f8f57fec0978bd')
+install="note.install"
+sha1sums=('SKIP' '719d18d69abc299f739cc04041967e9d05a34104')
_installpath='/usr/share/PINCE'
_installsh='install_pince.sh'
@@ -30,10 +31,26 @@ prepare() {
sed -i '/^if \[ ! -d "\.venv\/PINCE" \]; /,/activate$/ s/^/# /' "./$pkgname/PINCE.sh"
# Create a simple start script
cat > pince <<- SHELL
- #!/bin/bash
+ #!/usr/bin/env bash
+
+ syncicon() {
+ local logo_path iconpath destpath
+ . <(grep '^logo_path=.*' "\${XDG_CONFIG_HOME:-"\$HOME/.config"}/PINCE/PINCE.conf")
+ iconpath="/usr/share/PINCE/media/logo/\$logo_path"
+ destpath="\${XDG_DATA_HOME:-"\$HOME/.local/share"}/icons/hicolor/256x256/apps/PINCE.png"
+ mkdir -p "\$(dirname "\$destpath")"
+ ln -sf "\$iconpath" "\$destpath"
+ echo -e "\nDesktop icon updated: \$destpath"
+ echo "If the setting of icon changed, Re-login for setting to take effect."
+ }
+
pushd "$_installpath" || exit
sh PINCE.sh "\$@"
+ syncicon
popd || exit
+
+ read -p "Press enter to exit..."
+
SHELL
}
@@ -95,9 +112,7 @@ package() {
python -m compileall -s "$pkgdir" -p / "$pkgdir"/usr/share
# Install desktop entity
- install -d "$pkgdir"/usr/share/{applications,pixmaps}
- #ln -s '/usr/share/PINCE/media/logo/ozgurozbek/pince_big_white.png' \
- # "$pkgdir/usr/share/pixmaps/PINCE.png"
+ install -d "$pkgdir"/usr/share/applications
install -Dm755 PINCE.desktop "$pkgdir/usr/share/applications"
}
diff --git a/note.install b/note.install
new file mode 100644
index 000000000000..4c78ba5d23b1
--- /dev/null
+++ b/note.install
@@ -0,0 +1,18 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+pre_remove() {
+ note 'You probably want to remove the following file.'
+ msg_blue "\${XDG_DATA_HOME:-"\$HOME/.local/share"}/icons/hicolor/256x256/apps/PINCE.png"
+}