summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordetiam2023-09-28 15:57:05 +0800
committerdetiam2023-09-28 15:57:05 +0800
commit7e36afda8d0f869f48f836131e641a715733d3fd (patch)
treea79bc40294496ce453bc4f86d2d076e0b059db0b
parent450183b4a12878dccfd0c865db4db76da93e7658 (diff)
downloadaur-7e36afda8d0f869f48f836131e641a715733d3fd.tar.gz
hardcode depends
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD14
3 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a684cf7fcb27..b20f5956d026 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = pince-git
pkgdesc = A Linux reverse engineering tool inspired by Cheat Engine.
- pkgver = r1339.210151e
+ pkgver = r1360.161758a
pkgrel = 1
url = https://github.com/korcankaraokcu/PINCE
arch = any
license = GPL3
makedepends = git
+ makedepends = qt6-tools
+ makedepends = lsb-release
depends = base-devel
depends = python3
- depends = qt6-tools
+ depends = gdb
+ optdepends = qt6-wayland: wayland support
source = pince-git::git+https://github.com/korcankaraokcu/PINCE.git
source = PINCE.desktop
sha256sums = SKIP
@@ -17,7 +20,7 @@ pkgbase = pince-git
pkgname = pince-git
depends = base-devel
depends = python3
- depends = qt6-tools
+ depends = gdb
depends = python-distorm
depends = python-gobject
depends = python-keystone
diff --git a/.gitignore b/.gitignore
index 42810bfec0ba..71ff8a0c92f1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
*
!.SRCINFO
-!.PKGBUILD
+!PKGBUILD
!.gitignore
!PINCE.* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 617112be8cfc..db2ef74f9241 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,17 @@
# shellcheck disable=SC1090,SC2206
pkgname=pince-git
-pkgver=r1339.210151e
+pkgver=r1360.161758a
pkgrel=1
pkgdesc="A Linux reverse engineering tool inspired by Cheat Engine."
arch=('any')
url="https://github.com/korcankaraokcu/PINCE"
license=('GPL3')
-depends=('base-devel' 'python3' 'qt6-tools') # follow upstream, set this later
-makedepends=('git')
+depends=('base-devel' 'python3' 'gdb')
+makedepends=('git' 'qt6-tools' 'lsb-release')
+optdepends=(
+ 'qt6-wayland: wayland support'
+)
source=("$pkgname::git+$url.git" 'PINCE.desktop')
sha256sums=('SKIP' '33f145e61784d9f50b391e880d14a9d31a13d7b86cef0c8620f8f57fec0978bd')
_installpath='/usr/share/PINCE'
@@ -25,8 +28,6 @@ pkgver() {
prepare() {
# Remove ".venv/PINCE" exist check
sed -i '/^if \[ ! -d "\.venv\/PINCE" \]; /,/activate$/ s/^/# /' "./$pkgname/PINCE.sh"
- # This env is no longer needed
- sed -i 's| PYTHONDONTWRITEBYTECODE=1||' "./$pkgname/PINCE.sh"
# Create a simple start script
cat > pince <<- SHELL
#!/bin/bash
@@ -57,8 +58,7 @@ package() {
# Source PKG_NAMES* vars
. <(sed -n '/^PKG_NAMES/p' $_installsh)
- # Set new depends
- depends+=($PKG_NAMES_ARCH)
+ # Add new python depends
for pipkg in $PKG_NAMES_PIP; do
echo 'Added new depend '"$pipkg"''
if [ "$pipkg" == "distorm3" ]; then