summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordetiam2023-06-14 11:21:46 +0800
committerdetiam2023-06-14 11:21:46 +0800
commitc1addbc1c62153d2fe5507d48813f2a2f8fe5bcc (patch)
tree1c12bd2454f4770a180aafef77ea7a75b88882da
parent80d6f913a2cccadfce5401aa5f38f1f209b461de (diff)
downloadaur-c1addbc1c62153d2fe5507d48813f2a2f8fe5bcc.tar.gz
Depends clean up
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ade8394249ee..1bf069443b88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pince-git
pkgdesc = A Linux reverse engineering tool inspired by Cheat Engine.
- pkgver = r1277.53022ff
+ pkgver = r1300.7111db9
pkgrel = 1
url = https://github.com/korcankaraokcu/PINCE
arch = any
@@ -13,6 +13,3 @@ pkgbase = pince-git
pkgname = pince-git
depends = base-devel
- depends = python-distorm
- depends = python-gobject
- depends = python-pince-git
diff --git a/PKGBUILD b/PKGBUILD
index a4ab956d9f47..9719197280f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# shellcheck disable=SC1090
# shellcheck disable=SC2206
pkgname=pince-git
-pkgver=r1277.53022ff
+pkgver=r1300.7111db9
pkgrel=1
pkgdesc="A Linux reverse engineering tool inspired by Cheat Engine."
arch=('any')
@@ -51,15 +51,17 @@ package() {
. <(sed -n '/^PKG_NAMES/p' install_pince.sh)
# Set new depends
depends+=($PKG_NAMES_ARCH)
- for pkg in $PKG_NAMES_PIP; do
- ## why archlinux python package isn't just match "python-$pkg" format?
+ for pipkg in $PKG_NAMES_PIP; do
+ ## why archlinux python package isn't just match "python-$pipkg" format?
## and one of these depends in aur are outdated now 2023/05/08
- if [ "$pkg" == "distorm3" ]; then
+ if [ "$pipkg" == "distorm3" ]; then
depends+=("python-distorm")
- elif [ "$pkg" == "pygobject" ]; then
+ elif [ "$pipkg" == "pygobject" ]; then
depends+=("python-gobject")
+ elif [ "$pipkg" == "keystone-engine" ]; then
+ depends+=("python-keystone")
else
- depends+=("python-$pkg")
+ depends+=("python-$pipkg")
fi
done
# Copy files