summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordetiam2023-08-01 03:25:46 +0800
committerdetiam2023-08-01 03:25:46 +0800
commitcfdcc499ef2565c31f771029b0dbceaf53d8904f (patch)
tree7e37ac8be96dd684e1d5cbe566c4793ba3d04016
parentf6f1cc07d949b7de558175a763029ab78f06be2c (diff)
downloadaur-cfdcc499ef2565c31f771029b0dbceaf53d8904f.tar.gz
Add desktop file
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore3
-rw-r--r--PINCE.desktop12
-rw-r--r--PKGBUILD21
4 files changed, 41 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75a11a44019a..b3c8d601a7ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,16 @@ pkgbase = pince-git
makedepends = intltool
depends = base-devel
source = pince-git::git+https://github.com/korcankaraokcu/PINCE.git
- md5sums = SKIP
+ source = PINCE.desktop
+ sha256sums = SKIP
+ sha256sums = 33f145e61784d9f50b391e880d14a9d31a13d7b86cef0c8620f8f57fec0978bd
pkgname = pince-git
depends = base-devel
+ depends = python-distorm
+ depends = python-gobject
+ depends = python-keystone
+ depends = python-pyqt6
+ depends = python-pexpect
+ depends = python-pygdbmi
+ depends = python-keyboard
diff --git a/.gitignore b/.gitignore
index fd7d127e6182..42810bfec0ba 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*
!.SRCINFO
!.PKGBUILD
-!.gitignore \ No newline at end of file
+!.gitignore
+!PINCE.* \ No newline at end of file
diff --git a/PINCE.desktop b/PINCE.desktop
new file mode 100644
index 000000000000..949efe5831b1
--- /dev/null
+++ b/PINCE.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=PINCE
+Comment=Reverse engineering tool for linux games
+Comment[zh_CN]=用于 Linux 游戏的逆向工程工具
+GenericName=PINCE
+Exec=pince %U
+#Icon=PINCE
+Type=Application
+Terminal=true
+StartupNotify=false
+Categories=Qt;Utility;Development;
+MimeType=x-scheme-handler/PINCE; \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 15fab7c6defa..940f30b3a12a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,8 @@ url="https://github.com/korcankaraokcu/PINCE"
license=('GPL3')
depends=('base-devel') # follow upstream, set this later
makedepends=('git' 'intltool')
-source=("$pkgname::git+$url.git")
-md5sums=('SKIP')
+source=("$pkgname::git+$url.git" 'PINCE.desktop')
+sha256sums=('SKIP' '33f145e61784d9f50b391e880d14a9d31a13d7b86cef0c8620f8f57fec0978bd')
_installpath='/usr/share/PINCE'
_installsh='install_pince.sh'
@@ -49,13 +49,16 @@ build() {
}
package() {
- cd "$pkgname"
+
+ pushd "$pkgname"
+
# Source PKG_NAMES* vars
. <(sed -n '/^PKG_NAMES/p' $_installsh)
+
# Set new depends
depends+=($PKG_NAMES_ARCH)
for pipkg in $PKG_NAMES_PIP; do
- ## why archlinux python package isn't just match "python-$pipkg" format?
+ echo 'Added new depend '"$pipkg"''
if [ "$pipkg" == "distorm3" ]; then
depends+=("python-distorm")
elif [ "$pipkg" == "pygobject" ]; then
@@ -66,6 +69,7 @@ package() {
depends+=("python-$pipkg")
fi
done
+
# Copy files
install -d "$pkgdir/usr/bin"
install -Dm755 ../pince "$pkgdir/usr/bin"
@@ -74,4 +78,13 @@ package() {
COPYING COPYING.CC-BY AUTHORS THANKS "$pkgdir/$_installpath"
cp -r GUI libpince media tr "$pkgdir/$_installpath"
cp -r i18n/qm "$pkgdir/$_installpath/i18n"
+
+ popd
+
+ # Install desktop entity
+ install -d "$pkgdir"/usr/share/{applications,pixmaps}
+ #ln -s '/usr/share/PINCE/media/logo/ozgurozbek/pince_big_white.png' \
+ # "$pkgdir/usr/share/pixmaps/PINCE.png"
+ install -Dm755 PINCE.desktop "$pkgdir/usr/share/applications"
+
}