summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortinywrkb2020-09-19 19:26:45 +0300
committertinywrkb2020-09-19 19:26:45 +0300
commit782d509ffaff328a2bb86bf2914c38d98ea1fa1b (patch)
treed690c84f1aa73ae3e43aab682cebbffe9cb2ebf1
parent1f46bc61796d4459b76988dcb806329edf320c1e (diff)
downloadaur-782d509ffaff328a2bb86bf2914c38d98ea1fa1b.tar.gz
bump to 0.3.12-2: enable ffmpeg
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6507d1c3f7b6..0deb0e1f60ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pipewire-gstfree
pkgdesc = Server and user space API to deal with multimedia pipelines. packaged without gstreamer dependencies
pkgver = 0.3.12
- pkgrel = 1
+ pkgrel = 2
url = https://pipewire.org
arch = x86_64
license = LGPL2.1
@@ -21,6 +21,7 @@ pkgbase = pipewire-gstfree
makedepends = libsndfile
makedepends = bluez-libs
makedepends = vulkan-headers
+ makedepends = ffmpeg
source = git+https://github.com/PipeWire/pipewire#commit=fc0354ae1d74e5b3681ff852507d9bc1719027d5
sha256sums = SKIP
@@ -30,6 +31,7 @@ pkgname = pipewire-gstfree
depends = rtkit
depends = vulkan-icd-loader
depends = bluez-libs
+ depends = ffmpeg
depends = libdbus-1.so
depends = libsndfile.so
depends = libudev.so
diff --git a/PKGBUILD b/PKGBUILD
index ebdd9a881521..63b05e5e71f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,16 +8,16 @@ pkgbase=pipewire-gstfree
_pkgbase=pipewire
pkgname=(pipewire-gstfree pipewire-gstfree-docs pipewire-gstfree-jack pipewire-gstfree-pulse pipewire-gstfree-alsa)
pkgver=0.3.12
-pkgrel=1
+pkgrel=2
pkgdesc="Server and user space API to deal with multimedia pipelines. packaged without gstreamer dependencies"
url="https://pipewire.org"
license=(LGPL2.1)
arch=(x86_64)
makedepends=(git meson doxygen graphviz xmltoman valgrind jack2 libpulse
alsa-lib sbc rtkit vulkan-icd-loader
- dbus libsndfile bluez-libs vulkan-headers)
+ dbus libsndfile bluez-libs vulkan-headers ffmpeg)
_commit=fc0354ae1d74e5b3681ff852507d9bc1719027d5
-source=("git+https://github.com/PipeWire/pipewire#commit=$_commit")
+source=("git+https://github.com/PipeWire/pipewire#commit=$_commit") # tags/0.3.12
sha256sums=('SKIP')
pkgver() {
@@ -32,6 +32,7 @@ prepare() {
build() {
arch-meson $_pkgbase build \
-D gstreamer=false \
+ -D ffmpeg=true \
-D docs=true \
-D udevrulesdir=/usr/lib/udev/rules.d
meson compile -C build
@@ -54,7 +55,7 @@ _pick() {
_ver=${pkgver:0:3}
package_pipewire-gstfree() {
- depends=(sbc rtkit vulkan-icd-loader bluez-libs
+ depends=(sbc rtkit vulkan-icd-loader bluez-libs ffmpeg
libdbus-1.so libsndfile.so libudev.so libasound.so libsystemd.so
libglib-2.0.so libgobject-2.0.so)
optdepends=('pipewire-docs: Documentation'