summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDobroslaw Kijowski2016-02-22 23:50:43 +0100
committerDobroslaw Kijowski2016-02-22 23:50:43 +0100
commit38aef999bcde3a3064b64cf443659df3541edff0 (patch)
treee983ba12a40a048d1d371ddb341e9044f9ce3077
downloadaur-piratescope-git.tar.gz
* Initial commit.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
-rw-r--r--select_wx_2.8.patch20
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5182620cc22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Mon Feb 22 22:50:26 UTC 2016
+pkgbase = piratescope-git
+ pkgdesc = A simple oscilloscope client for the Bus Pirate universal serial interface.
+ pkgver = r30.e6d10c7
+ pkgrel = 1
+ url = https://github.com/tgvaughan/PirateScope
+ arch = any
+ license = GPL3
+ makedepends = python2-setuptools
+ makedepends = git
+ depends = wxpython2.8
+ depends = python2-numpy
+ depends = python2-numarray
+ source = git://github.com/tgvaughan/PirateScope.git
+ source = select_wx_2.8.patch
+ md5sums = SKIP
+ md5sums = d37f1e8c8c054f7120958dd282975dd3
+
+pkgname = piratescope-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b25830bf8285
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer : Dobroslaw Kijowski [dobo] <dobo90_at_gmail.com>
+
+pkgname=piratescope-git
+_pkgname=PirateScope
+pkgver=r30.e6d10c7
+pkgrel=1
+pkgdesc='A simple oscilloscope client for the Bus Pirate universal serial interface.'
+arch=(any)
+url='https://github.com/tgvaughan/PirateScope'
+license=(GPL3)
+depends=(wxpython2.8 python2-numpy python2-numarray)
+makedepends=(python2-setuptools git)
+source=(git://github.com/tgvaughan/PirateScope.git select_wx_2.8.patch)
+md5sums=(SKIP d37f1e8c8c054f7120958dd282975dd3)
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ patch -p1 < ../select_wx_2.8.patch
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ install -D -m 755 "${_pkgname}" "${pkgdir}/usr/bin/piratescope"
+}
diff --git a/select_wx_2.8.patch b/select_wx_2.8.patch
new file mode 100644
index 000000000000..25124405fbdc
--- /dev/null
+++ b/select_wx_2.8.patch
@@ -0,0 +1,20 @@
+diff --git a/PirateScope b/PirateScope
+index c71203f..c9d1f6e 100755
+--- a/PirateScope
++++ b/PirateScope
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ # PirateScope - Oscilloscope script for Dangerous Prototypes' Bus Pirate
+ # Copyright (C) 2010 Tim Vaughan
+@@ -16,6 +16,9 @@
+ # You should have received a copy of the GNU General Public License
+ # along with this program. If not, see <http://www.gnu.org/licenses/>.
+
++import wxversion
++wxversion.select('2.8')
++
+ import wx
+ from wx.lib import plot
+ from wx.lib.wordwrap import wordwrap