summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKishore Gopalakrishnan2024-03-31 18:43:29 +0530
committerKishore Gopalakrishnan2024-03-31 18:44:56 +0530
commitcabbd2335d156d513d3c94b11af0b786a5522a9d (patch)
treed0866bd835f61ac2f21901c16e724a8f47803be9
downloadaur-plasma6-runners-appmenu-git.tar.gz
Initial commit
Slightly modified version of the plasma5-runners-appmenu-git package.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
-rw-r--r--plasma6-runners-appmenu-git.install3
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60986a2dd4dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = plasma6-runners-appmenu-git
+ pkgdesc = A little krunner plugin (Plasma 6) to search through the menu items of the current application.
+ pkgver = r16.f705ea0
+ pkgrel = 1
+ url = https://github.com/Kishore96in/krunner-appmenu
+ install = plasma6-runners-appmenu-git.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = krunner
+ depends = python
+ depends = python-xlib
+ depends = python-dbus
+ depends = python-gobject
+ conflicts = plasma5-runners-appmenu-git
+ source = git+https://github.com/Kishore96in/krunner-appmenu.git
+ md5sums = SKIP
+
+pkgname = plasma6-runners-appmenu-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e73dc225385c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Kishore G <kishore96 at gmail dot com>
+pkgname=plasma6-runners-appmenu-git
+pkgver=r16.f705ea0
+pkgrel=1
+pkgdesc="A little krunner plugin (Plasma 6) to search through the menu items of the current application."
+arch=('any')
+url="https://github.com/Kishore96in/krunner-appmenu"
+license=('GPL')
+groups=()
+depends=('krunner' 'python' 'python-xlib' 'python-dbus' 'python-gobject')
+makedepends=('git')
+conflicts=('plasma5-runners-appmenu-git')
+install="plasma6-runners-appmenu-git.install"
+source=("git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd krunner-appmenu
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd krunner-appmenu
+
+ mkdir -p "$pkgdir"/usr/share/krunner/dbusplugins
+ cp plasma-runner-krunner_appmenu.desktop "$pkgdir"/usr/share/krunner/dbusplugins
+
+ mkdir -p "$pkgdir"/usr/bin
+ cp krunner_appmenu.py "$pkgdir"/usr/bin/
+
+ mkdir -p "$pkgdir"/etc/xdg/autostart
+ sed "s|@PROJECTDIR@|/usr/bin|" krunner_appmenu_autostart.desktop.in > "$pkgdir"/etc/xdg/autostart/krunner_appmenu_autostart.desktop
+}
diff --git a/plasma6-runners-appmenu-git.install b/plasma6-runners-appmenu-git.install
new file mode 100644
index 000000000000..8a716d49c2ee
--- /dev/null
+++ b/plasma6-runners-appmenu-git.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "Note that by default, /usr/bin/krunner_appmenu.py will be autostarted."
+}